Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-23838

PathPrefix not working with Symfony Stack

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: 5.0, 5.1, 5.2, 5.3, 5.4.0, dev-master
    • Fix Version/s: QA tracked issues
    • Component/s: Documentation
    • Labels:
    • Sprint:
      Pollux Core S5

      Description

      Apparently PathPrefix stopped working after 4.7 due to Symfony Stack, even if legacy_mode: true is used. However, using pure legacy, PathPrefix works perfectly

      The output throwned in ezpublish_legacy/var/log/error.log is

      [ Dec 29 2014 16:30:40 ] [10.0.5.1] index:
      Undefined module: info
      [ Dec 29 2014 16:30:40 ] [10.0.5.1] error/view.php:
      Error ocurred using URI: /info
      

      In the case you create the following structure

      Home
      -> News
      -> info

      Add to site.ini.append.php

      [SiteAccessSettings]
      PathPrefix=News

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                pedro.resende-obsolete@ez.no Pedro Resende (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 1 hour, 15 minutes
                  1h 15m