Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-20636

Restoring a removed object to the original location is always unavailable

    Details

      Description

      Hi,

      When i remove an object to trash and then try to restore it to original location i always have the radio option for "Restore at original location" disabled and the information that the location is unavailable (Restore at original location (unavailable))

      To reproduce:

      • Create an article
      • remove the article
      • Go to trash can
      • Select the removed article and press the button to recover

        Issue Links

          Activity

          Hide
          Jérôme Vieilledent (Inactive) added a comment -

          Regression from EZP-20492

          Show
          Jérôme Vieilledent (Inactive) added a comment - Regression from EZP-20492
          Show
          Jérôme Vieilledent (Inactive) added a comment - Pull request : https://github.com/ezsystems/ezpublish-legacy/pull/590
          Show
          Jérôme Vieilledent (Inactive) added a comment - Fixed in master : https://github.com/ezsystems/ezpublish-legacy/commit/540ba25434ffc1e55c6e4eb75b9b3ba18c53e350
          Hide
          Paulo Nunes (Inactive) added a comment -

          QA Approved
          Tested on master and ezp4.3
          Tested on 4.3 after applying EZP-20492 patch that causes the regression.
          Also executed tc-1531

          Show
          Paulo Nunes (Inactive) added a comment - QA Approved Tested on master and ezp4.3 Tested on 4.3 after applying EZP-20492 patch that causes the regression. Also executed tc-1531
          Hide
          Gunnstein Lye added a comment -

          Reopen for more QA

          Show
          Gunnstein Lye added a comment - Reopen for more QA
          Hide
          Paulo Nunes (Inactive) added a comment -

          QA Approved
          Tested on 4.7 and 5.0. To reproduce the issues on each of these versions, service packs were applied until the last Sp before the already approved one, respectively.
          For eZ Publish 4.6, with all released service packs applied, the issue is no longer reproducible. Nevertheless i applied the fix and did sanity tests to verify if everything was ok and nothing have been broken.

          Show
          Paulo Nunes (Inactive) added a comment - QA Approved Tested on 4.7 and 5.0. To reproduce the issues on each of these versions, service packs were applied until the last Sp before the already approved one, respectively. For eZ Publish 4.6, with all released service packs applied, the issue is no longer reproducible. Nevertheless i applied the fix and did sanity tests to verify if everything was ok and nothing have been broken.

            People

            • Assignee:
              Unassigned
              Reporter:
              Paulo Nunes (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 7 hours
                7h