Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-31203

In Multirepository setup Installer always use a default Database connection for checking if the database exists

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: 2.5.6
    • Fix Version/s: Customer request, 2.5.9
    • Component/s: Install
    • Labels:
      None

      Description

      In Multirepository setup --siteaccess option used to change Siteaccess used for Command (and repository change by extension) is ignored when choosing Database connection for database existence check.

      Steps to reproduce
      1. Clean installation of eZ Platform 2.5.6
      2. Multirepository setup with two Databases: db-1 and db-2.
      3. Two backends Siteaccesses admin and admin2, using different cache.pool and repository. admin uses default repository (db-1), admin2 uses second repository (db-2).
      4. Execute:

      php bin/console ezplatform:install ezplatform-ee-clean --siteaccess=admin2
      

      Result

      Creating the database db-1 if it does not exist

      Expected Result

      Creating the database db-2 if it does not exist

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              mateusz.bieniek@ez.no Mateusz Bieniek
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: