Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-30121

Base table or view not found: Table ezpreferences doesn't exist

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Composer, Install
    • Labels:
      None

      Description

      Hi,
      starting from scratch and following the steps to build and deploy for production environments (here: https://github.com/ezsystems/ezplatform/tree/master/doc/docker#production-use), the first step does not work as expected, since the Composer's cache clear does not find the tables on DB. Here the logs from docker-compose:

      install_app_1  |   17:03:05 ERROR     [console] Error thrown while running command "cache:clear --no-warmup". Message: "Database error" ["exception" => RuntimeException { …},"command" => "cache:clear --no-warmup","message" => "Database error"]
      install_app_1  |
      install_app_1  |   In ExceptionConversion.php line 44:
      install_app_1  |
      install_app_1  |     Database error
      install_app_1  |
      install_app_1  |
      install_app_1  |   In AbstractMySQLDriver.php line 42:
      install_app_1  |
      install_app_1  |     An exception occurred while executing 'SELECT id, name, user_id, value FROM
      install_app_1  |      ezpreferences WHERE (user_id = ?) AND (name = ?)' with params [10, "langua
      install_app_1  |     ge"]:
      install_app_1  |
      install_app_1  |     SQLSTATE[42S02]: Base table or view not found: 1146 Table 'ezplatform.ezpre
      install_app_1  |     ferences' doesn't exist
      install_app_1  |
      install_app_1  |
      install_app_1  |   In PDOStatement.php line 119:
      install_app_1  |
      install_app_1  |     SQLSTATE[42S02]: Base table or view not found: 1146 Table 'ezplatform.ezpre
      install_app_1  |     ferences' doesn't exist
      install_app_1  |
      install_app_1  |
      install_app_1  |   In PDOStatement.php line 117:
      install_app_1  |
      install_app_1  |     SQLSTATE[42S02]: Base table or view not found: 1146 Table 'ezplatform.ezpre
      install_app_1  |     ferences' doesn't exist
      

      I would expecting that starting from scratch these steps would have installed all the necessary resources, including the database schema, because I'm configuring a build and deploy pipeline.

      Thank you

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              maxgio Massimiliano Giovagnoli
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: