Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-26966

Backport compatibility with Twig 2 to 5.4.x

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: 5.4.9
    • Fix Version/s: Customer request, 5.4.10
    • Component/s: Legacy stack
    • Labels:
      None

      Description

      Since the compatibility with Twig 2 has been added on LegacyBridge (ref), it would be very useful to have this backported to 5.4.

      For the moment, if we have an environment with symfony 2.8.x and twig 2.1.x we get errors like such:

      PHP Fatal error: Class 'Twig_Loader_String' not found in /Path_to_ezp54/vendor/ezsystems/ezpublish-kernel/eZ/Publish/Core/MVC/Symfony/Templating/Twig/LoaderString.php on line 18
      

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              ricardo.correia-obsolete@ez.no Ricardo Correia (Inactive)
            • Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: