Details

    • Type: Improvement Improvement
    • Status: Confirmed
    • Priority: Medium Medium
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None

      Description

      JavaScript development has largely standardised on NPM as the packet manager of choice. NPM is nowadays used for both backend (Node.js) and front end JavaScript development. The eZ JS CAPI is now published via the Bower packet management which is a front end packet management solution that has become a niche product.

      To enable JavaScript developers to use their standard development workflows (complete with module bundling, transpiling, etc.) with popular frameworks such as Angular, React and Vue, eZ CAPI should be made compatible with NPM and the library should be published on the NPM module registry.

      Ideally developers should be able to include eZ CAPI as follows:

      npm install ezcapi --save
      

      and then use the eZ CAPI library just like any other NPM library with popular project scaffolding, like:

      This will help drive adoption of the eZ CAPI outside of Platform UI. As it stands the CAPI is simply not usable at all for the above projects, rendering it a curiosity.

        Activity

        There are no comments yet on this issue.

          People

          • Assignee:
            Unassigned
            Reporter:
            Jani Tarvainen
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated: