Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-25291

No `languageCode` is set when creating a new content after canceling previous new content creation

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: High High
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2015.11.2
    • Fix Version/s: None
    • Labels:
      None

      Description

      The 'languageCode' is not set when creating a new content.
      Steps to reproduce:
      1). Create a new blog post,
      2). Cancel the process by clicking on X button,
      3). Create a new blog post again,
      4). Language code is not set.

      https://www.youtube.com/watch?v=CbG9TUc6h8I

        Issue Links

          Activity

          Hide
          Damien Pobel (Inactive) added a comment -

          I'm not able to reproduce that in a setup with only PlatformUI. You are using a UI coming from Studio in your screencast but this is not happening if you go to "Content structure" and then follow your step to reproduce. So I guess something is wrongly done in Studio or maybe trigger a bug in PlatformUI.

          One technical advice: in PlatformUI, the language code of the Content that will be created is hardcoded when firing the createContent event and this language code is then passed to the create content view service by the eZ.Plugin.ContentCreate plugin. It's quite simple so if something around that does not work in Studio, you should look there and put some breakpoints to figure out what's going on.

          Show
          Damien Pobel (Inactive) added a comment - I'm not able to reproduce that in a setup with only PlatformUI. You are using a UI coming from Studio in your screencast but this is not happening if you go to "Content structure" and then follow your step to reproduce. So I guess something is wrongly done in Studio or maybe trigger a bug in PlatformUI. One technical advice: in PlatformUI, the language code of the Content that will be created is hardcoded when firing the createContent event and this language code is then passed to the create content view service by the eZ.Plugin.ContentCreate plugin . It's quite simple so if something around that does not work in Studio, you should look there and put some breakpoints to figure out what's going on.

            People

            • Assignee:
              Unassigned
              Reporter:
              Piotr Nalepa
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: