Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-25048

No `languageCode` is set when creating a new content as a child of freshly created content

    XMLWordPrintable

    Details

      Description

      When creating a new content (a blog post) in eZ Studio as a child of freshly created content (blog post) the language selector is not set correctly.
      This disallows to create a new content in eZ Platform combined with eZ Studio.
      From my investigation, in the file: ez-contenteditviewservice.js in _setLanguageCode method there's missing fallback to the language code of parent content. It always expects the language code to be sent through the request.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              piotr.nalepa-obsolete@ez.no Piotr Nalepa (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 2 days, 1 hour, 30 minutes
                  2d 1h 30m