Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-24821

Session terminates when page reloaded anywhere on PlatformUI

    Details

      Description

      Steps to reproduce.
      1. Go anywhere in PlatformUI;
      2. Open firebug or similar tool;
      3. Reload the page manually. Verify that you are logged out, and you shouldn't.
      4. Verify on firebug console that you have an error:

      POST http://ezp5.rui/api/ezp/v2/user/sessions/53rvvqpa3l0fpr5knet3ej5bd5/refresh     500 Internal Server Error     623ms               	
      CAPI.js (line 1406)
      "NetworkError: 500 Internal Server Error - http://ezp5.rui/api/ezp/v2/user/sessions/53rvvqpa3l0fpr5knet3ej5bd5/refresh"
      refresh
      Password fields present on an insecure (http://) page. This is a security risk that allows user login credentials to be stolen.
      

      The response body of the error is:

      503 Service Unavailable{"ErrorMessage":{"_media-type":"application\/vnd.ez.api.ErrorMessage+json","errorCode":500,"errorMessage":"Internal Server Error","errorDescription":"Attempted to load class \"ezxFormToken\" from the global namespace.\nDid you forget a \"use\" statement?","trace":"#0 {main}","file":"\/var\/www\/html\/ezpublish5\/vendor\/ezsystems\/legacy-bridge\/bundle\/EventListener\/RestListener.php","line":52}}
      

        Activity

        Hide
        Damien Pobel (Inactive) added a comment -

        weird, are you sure ezpublish legacy is correctly installed ?

        Show
        Damien Pobel (Inactive) added a comment - weird, are you sure ezpublish legacy is correctly installed ?
        Hide
        Rui Silva (Inactive) added a comment -

        I'm not sure about legacy being correctly installed, but I removed it, and now the problem is gone.
        Shall I close this then as invalid [~damien.pobel@ez.no]?
        I'll remove the blockage that much, at least.

        Show
        Rui Silva (Inactive) added a comment - I'm not sure about legacy being correctly installed, but I removed it, and now the problem is gone. Shall I close this then as invalid [~damien.pobel@ez.no] ? I'll remove the blockage that much, at least.

          People

          • Assignee:
            Unassigned
            Reporter:
            Rui Silva (Inactive)
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: