Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-24817

Error creating content in languages other than the default;

    Details

      Description

      Steps to reproduce:

      1. Go to PlatformUI;

      2. Go to "Content -> Content Structure";

      3. Create some content (a Folder or a Link);

      4. On content creation view, click on the top right corner language switcher in order to change the language in which you'll edit the content;

      5. Pick another language such as fre-FR, and name the content with something;

      6. Open firebug or similar tool, and go to Console;

      7. Click "Publish".
      Check on the Console and you'll see the error:

      POST http://ezp5.rui/api/ezp/v2/content/objects        500 Internal Server Error  		833ms                    	CAPI.js (line 1406)
      "NetworkError: 500 Internal Server Error - http://ezp5.rui/api/ezp/v2/content/objects"                                                objects
      TypeError: response.document is null                                                                                 ez-publ...ugin.js (line 99, col 48)
      ...n.setAttrs(version.parse({document: response.document.Content.CurrentVersion}))
      

      The "Response" body on the error is:

      503 Service Unavailable{"ErrorMessage":{"_media-type":"application\/vnd.ez.api.ErrorMessage+json","errorCode":500,"errorMessage":"Internal Server Error","errorDescription":"Attempted to load class \"ezxFormToken\" from the global namespace.\nDid you forget a \"use\" statement?","trace":"#0 {main}","file":"\/var\/www\/html\/ezpublish5\/vendor\/ezsystems\/legacy-bridge\/bundle\/EventListener\/RestListener.php","line":52}}
      

        Activity

        Hide
        Mateusz Hyndle (Inactive) added a comment -

        I can't reproduce it. Tried in dev and prod envs.

        Show
        Mateusz Hyndle (Inactive) added a comment - I can't reproduce it. Tried in dev and prod envs.
        Hide
        Rui Silva (Inactive) added a comment -

        I just confirmed, this does not happen anymore.
        I don't have the same browser versions as when this was reported, but Chrome's is just a minor update away from the one it was reported at.
        Thus, this must have been fixed throughout the many updates to platformUI in the meanwhile.
        Will close this as invalid.

        Show
        Rui Silva (Inactive) added a comment - I just confirmed, this does not happen anymore. I don't have the same browser versions as when this was reported, but Chrome's is just a minor update away from the one it was reported at. Thus, this must have been fixed throughout the many updates to platformUI in the meanwhile. Will close this as invalid.

          People

          • Assignee:
            Unassigned
            Reporter:
            Rui Silva (Inactive)
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - Not Specified
              Not Specified
              Remaining:
              Remaining Estimate - 0 minutes
              0m
              Logged:
              Time Spent - 30 minutes
              30m