Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-23977

Missing feedback when the browser is not able to display an image

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Low Low
    • Resolution: Obsolete
    • Affects Version/s: 2015.01, 1.3.1, 1.4.0-beta1, 1.5.0
    • Fix Version/s: QA tracked issues
    • Labels:
      None
    • Environment:

      Operating System: CentOS 7.0 x64
      PHP Version: 5.4.16
      Database and version: Mariadb 5.5
      Browser (and version): Firefox 35 and Chrome 39

      Description

      When adding an image file which is not supported by the browser, PlatformUI should give a feedback to user instead of displaying only a white preview to the user. When displaying the image, the same should be done or maybe we should a variation that forces a format the navigation can display.

      Steps to Reproduce

      – Create a content -> image
      – Fill in the name (Image1) and upload or drag&drop a Tiff image file into "image" field
      (Here we can see that the image is uploaded, but no preview is seen)
      – Publish the image1
      (now we can see the "An error occurred while loading the image" error on the image placeholder)

        Issue Links

          Activity

          Hide
          Paulo Nunes (Inactive) added a comment -

          Currently we have a message referring that the content is invalid

          Show
          Paulo Nunes (Inactive) added a comment - Currently we have a message referring that the content is invalid

            People

            • Assignee:
              Unassigned
              Reporter:
              Paulo Nunes (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: