Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-23902

Documentation: Multiple User Providers example config not working

    XMLWordPrintable

    Details

      Description

      In eZ Publish 5.4, following the documentation for the multiple user providers feature (see https://doc.ez.no/display/EZP/How+to+authenticate+a+user+with+multiple+user+providers) results in an critical exception:

      request.CRITICAL: Uncaught PHP Exception RuntimeException: "No encoder has been configured for account "Symfony\Component\Security\Core\User\User"." at /var/www/ezp54/vendor/symfony/symfony/src/Symfony/Component/Security/Core/Encoder/EncoderFactory.php line 51 {"exception":"[object] (RuntimeException: No encoder has been configured for account \"Symfony\\Component\\Security\\Core\\User\\User\". at /var/www/ezp54/vendor/symfony/symfony/src/Symfony/Component/Security/Core/Encoder/EncoderFactory.php:51)"} []
      

      It seems the issue is a missing 'encoders' config in security.yml:

      security:
          ...
          encoders:
              Symfony\Component\Security\Core\User\User: plaintext
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                joao.inacio-obsolete@ez.no Joao Inacio (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 30 minutes
                  30m