Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-23189

Composer install/update fails on zetacomponents/base requirements

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2014.05, 5.3.2, 5.4-dev
    • Component/s: Composer
    • Labels:
    • Environment:

      Operating System: Debian 7
      PHP Version: PHP 5.4.4-14+deb7u8
      Database and version: Mysql 5.5.35
      Browser (and version): Firefox 30

    • Sprint:
      Castor Core S3

      Description

      Hi, When installing eZ Publish through git,i have the following error when doing the composer install

      Loading composer repositories with package information
      Installing dependencies (including require-dev)
      Your requirements could not be resolved to an installable set of packages.
      
        Problem 1
          - Installation request for ezsystems/ezpublish-kernel dev-master -> satisfiable by ezsystems/ezpublish-kernel[dev-master].
          - zetacomponents/signal-slot dev-master requires zetacomponents/base 1.8.* -> satisfiable by zetacomponents/base[1.8].
          - Can only install one of: zetacomponents/base[dev-master, 1.8].
          - ezsystems/ezpublish-legacy dev-master requires zetacomponents/signal-slot dev-master#74deb41 -> satisfiable by zetacomponents/signal-slot[dev-master].
          - ezsystems/ezpublish-kernel dev-master requires zetacomponents/base dev-master#642f63a -> satisfiable by zetacomponents/base[dev-master].
          - Installation request for ezsystems/ezpublish-legacy dev-master -> satisfiable by ezsystems/ezpublish-legacy[dev-master].
      
      
      Steps to Reproduce

      $ git clone git@github.com:ezsystems/ezpublish-platform.git ezpublish5
      $ cd ezpublish5
      $ curl -sS https://getcomposer.org/installer | php
      $ php composer.phar install --prefer-dist

      The problem information occurs when doing the composer install.

      Problem can also be reproduced by doing a full composer update on 5.3, workaround is to update as described in release notes, by specifying which packages to update.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                paulo.nunes-obsolete@ez.no Paulo Nunes (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: