Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-21732

Registering users with approval workflow is not working correctly

    Details

      Description

      Hi,

      The mails and messages received when registering a new user with approval workflow are not consistent

      Using the folliwng steps:

      (1) Create the following workflows

      • Before workflow
        • Event / Approve
          • Affected sections: Users
          • Affected versions: Publishing new object
        • Groups who approve: Administrators
      • After workflow
        • Event / Finish User Registration

      (2) Create the respective before/after triggers

      • Edit workflow.ini.append.php to add

        [OperationSettings]
        AvailableOperationList[]=user_activation
        

      • Go to the Setup/Triggers
        • content / publish / before -> Before workflow
        • user/ register / after -> After workflow

      (3) In fronpage, click on register
      (4) Register a new account with an email that you have access
      (5) Check email, and in the received email, click on the url to confirm the account
      (6) Here, we receive a message saying "Your account is now activated." (this should not happen. It should be something like "Your email address has been confirmed. An administrator needs to approve your sign up request, before your login becomes valid." )
      (7) After clicking in the line referred above, a new mail is received saying the "Your registration has been approved" (this should also not happen)
      (8)- As admin, approve the new registered user in Dashboard/collaboration and then execute the "frequent" cronjob
      (9) A new mail is received by the registered user asking to click a link to confirm the account
      (10) When clicking the link referred in the email, a new email is received saying the the account was activated (correct)

      I'm not sure if this sutuation is related to any of the following issues:
      https://jira.ez.no/browse/EZP-21599
      https://jira.ez.no/browse/EZP-20558
      https://jira.ez.no/browse/EZP-21563

        Activity

        Hide
        Bertrand Dunogier added a comment -

        And it doesn't happen on earlier versions ?

        Show
        Bertrand Dunogier added a comment - And it doesn't happen on earlier versions ?
        Hide
        Paulo Nunes (Inactive) added a comment -

        It doesn't happen on 5.1. Just re-checked.
        Tried again today, in ezp 5.2, with build #907 of BUL and it still happens.

        Show
        Paulo Nunes (Inactive) added a comment - It doesn't happen on 5.1. Just re-checked. Tried again today, in ezp 5.2, with build #907 of BUL and it still happens.
        Hide
        Bertrand Dunogier added a comment -

        What the...

        That's annoying

        Show
        Bertrand Dunogier added a comment - What the... That's annoying

          People

          • Assignee:
            Unassigned
            Reporter:
            Paulo Nunes (Inactive)
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated: