Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-21408

Use eZ Components from composer in standalone install

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: 5.2-dev
    • Fix Version/s: 5.2-alpha1
    • Component/s: 5.x > Legacy IO
    • Labels:
    • Environment:
      • eZ Publish Legacy (master)
      • Dependencies (-> eZ Components) installed through composer

      Description

      This affects eZ Publish legacy when not in context of eZ Publish 5.

      When the eZ components are not downloaded into lib/ezc and not installed through pear, but through the composer.json, generating autoloads fails with the message

      Warning: require(Base/src/base.php): failed to open stream: No such file or directory in .../ezpublish-legacy/bin/php/ezpgenerateautoloads.php on line 45

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            jgamez Jérôme Gamez
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 30 minutes
                30m