Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-20695

Errors when running Unit Tests with DATABASE=mysql://...

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.1 Certification, 5.1
    • Component/s: None
    • Labels:
      None

      Description

      When running the unit tests with DATABASE environment variable containing a "mysql://" DNS, plenty of errors are displayed, e.g.:

      1) eZ\Publish\Core\Repository\Tests\Service\Integration\Legacy\ContentTest::testLoadContentInfo
      PDOException: SQLSTATE[HY000]: General error: 1 near "ENGINE": syntax error
      
      eZ/Publish/Core/Persistence/Legacy/EzcDbHandler.php:112
      eZ/Publish/Core/Repository/Tests/Service/Integration/Legacy/Utils.php:56
      eZ/Publish/Core/Repository/Tests/Service/Integration/Legacy/Utils.php:56
      eZ/Publish/Core/Repository/Tests/Service/Integration/Legacy/Utils.php:32
      eZ/Publish/Core/Repository/Tests/Service/Integration/Legacy/ContentTest.php:21
      eZ/Publish/Core/Repository/Tests/Service/Integration/Base.php:36
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                patrick.allaert@ez.no Patrick Allaert (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 1 hour
                  1h