Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-18310

Failed Insertion of Non Translated Media Into Another Language Content Object

    XMLWordPrintable

    Details

      Description

      I have create some kind of media type object content - an image - in English.

      Then I create a content object, let's say an article, in French.

      By using the Insert/Edit image button in the toolbar I can browse for the image - in English - that I have just created and embed it into my article, without any error, warning, or filtering that says that the image does not exists for the article language.

      After I publish the article, it won't be show in my French site access, configured to show only french content.

      I understand that it makes sense in not showing the image file since the site acess is only for french content, but it doesn't make sense either to let the user choose a media content that won't be show in the front end.

      Steps to reproduce
      • Create an image content object in english.
      • Create an article content object in french.
      • Using the tool bar, link the created image into the article body.
      • Change the front end site.ini.append.php to show only french content.

      [RegionalSettings]
      Locale=por-PT
      ContentObjectLocale=fre-FR
      ShowUntranslatedObjects=disabled
      SiteLanguageList[]
      SiteLanguageList[]=fre-FR

        Attachments

          Activity

            People

            Assignee:
            unknown unknown
            Reporter:
            edf@ez.no Eduardo Fernandes
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated: