Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-17243

tc-118 (Oracle) Adding comments gives an DB error using the Article with Comments class in Oracle

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Medium Medium
    • Resolution: Fixed
    • Affects Version/s: 4.4.0beta2
    • Fix Version/s: QA tracked issues
    • Labels:
      None
    • Environment:

      Operating System: Linux
      Database and version: Oracle
      Browser (and version): Firefox 3.6.9

      Description

      Adding a comment to an "article with comments" object, in ORACLE, generates the error in attached image, if website field e the comment form is left empty. 
      This problem affect's the test cases  tc-118, tc-120 , tc-124, tc-149 and tc-235 in the 
      ezwebin -> Manual tests -> Comment System folder in test link.
      

      Steps to reproduce

      1. Run filter - 
      --filter="eZCommentsSeleneseTests::.*initialize_and_create_object.html"
       
      2. Create or use already existent "Article with comments" object.
       
      3. Log to ewbin interface and add a comment the an "article with comment" object
       
      4. Leave the website field empty, and add a comment.
      
      

        Issue Links

          Activity

          Gaetano Giunta added a comment -

          Sorry, but the error in the image is generated when running a cronjob, not when creating an article or a comment.

          Can rewrite the how-to-reproduce outside the unit-test harness?

          Geir Arne Waaler added a comment -

          The issue is fixed. I move it to Closed.

          Geir Arne Waaler
          eZ Documentation


            People

            • Assignee:
              Chen Xiongjie
              Reporter:
              João Pingo
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: