Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-17210

eZFind searching for class attributes NAME:INTEGER (serching for integer)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Medium Medium
    • Resolution: Fixed
    • Affects Version/s: 3.10.0, 3.10.0beta1, 4.0.0, 4.0.0alpha1, 4.0.0beta1, 4.2.0, 4.2.0alpha1, 4.2.0beta1, 4.2.0rc1, 4.3.0, 4.3.0beta1, 4.3.0rc1
    • Fix Version/s: 4.4.0beta1, QA tracked issues
    • Labels:
      None
    • Environment:

      Operating System: Linux
      PHP Version: 5.2
      Database and version: Oracle/mysql
      Browser (and version): Firefox 3.6

      Description

      <code>
      If we create a class type with Name and Integer, create a content with that, Name: Article A

      Integer: 2

      search for the integer number we inserted (2) in the search box,
      the search result will come up empty.

      But if we search for "Article A" the search is returned.

      If I Search for "A" it returns "NumberA" --> "1"
      If I Search for "B" it returns "NumberB" --> "2"
      If I Search for "C" it returns "NumberC" --> "3"

      But no results for "1" or "2" or "3"....

      BUT if I do an ADVANCED search, and say that I wanna search ONLY on class: testInteger, on CLASS ATTRIBUTE: number

      it returns badly....
      If I search for 3 on advance search, it will return:

      Search for <3> returned 3 matches
      Name Type
      NumberA tInteger test
      NumberC tInteger test
      NumberB tInteger test

      Steps to reproduce

      Steps  	
       
      Create class
         1. Log in as admin in admin interface
         2. Click "Setup" in top menu
         3. Click "Classes" in left menu
         4. Click "Content" link below Class group
         5. Click "New class" button
         6. Enter formdata:
            Name : tInteger test
            Identifier : tinteger
            Object Name Pattern : <name>
         7. Click "Add attribute" button (Adding a Textline attribute )
         8. Enter attribute data:
            Name : Name
            Identifier : name
         9. Select integer in datatype dropdown and click "Add attribute" button again
        10. Enter attribute data:
            Name : Number
            Identifier : number
       
      Setup - Create content : folder
         1. Click "Content structure" in top menu
         2. Select "Folder" in class drop down
         3. Click "Create here" button
         4. Enter form data:
            Name : News
         5. Click "Send for publishing" button
         6. Click "News" link
       
      Setup - Create content : NumberA
         1. Select "tInteger test" in drop down
         2. Click "Create here" button
         3. Enter form data:
            Name : NumberA
            Number : 1
         4. Click "Send for publishing" button
       
      Setup - Create content : NumberC
         1. Select "tInteger test" in drop down
         2. Click "Create here" button
         3. Enter form data:
            Name : NumberC
            Number : 3
         4. Click "Send for publishing" button
       
      Setup - Create content : NumberB
         1. Select "tInteger test" in drop down
         2. Click "Create here" button
         3. Enter form data:
            Name : NumberB
            Number : 2
         4. Click "Send for publishing" button
       
      Validate that searching for integers works
         1. In the search box in the top header, write : 1
         2. Click "Search" button
         3. Validate that you get match on ArticleA
         4. In the search box in the top header, write : 2
         5. Click "Search" button
         6. Validate that you get match on ArticleB
         7. In the search box in the top header, write : 3
         8. Click "Search" button
         9. Validate that you get match on ArticleC
      
      

      1. output_from_solr.txt
        33 kB
        Ricardo Goulart
      1. ezfind_integetBug.png
        22 kB

        Activity

        Ricardo Goulart added a comment -

        output_from_solr.txt Ouput from Solr

        Ricardo Goulart added a comment -

        Well it seems that the "code" blocks do not want to work.....
        And it also seems that I can only add ONE attachment....
        So on the issue you have the Solr Output and here you have a print screen!!ezfind_integetBug.png|thumbnail!

        Paul Borgermans added a comment -

        Its actually more a configuration issue, but I added default settings in ezfind.ini so integers are indexed as a string for searching and to dedicated types for the rest (facets/filtering/sorting)

        Fixed in rev 4814 (ezfind 2.3/trunk)

        ezrobot added a comment -

        This issue has been automatically closed due to the lack of activity over a long period of time. It is very likely that it is obsolete, but if you think it is still valid, do not hesitate to reopen it and mention why.


          People

          • Assignee:
            Unassigned
            Reporter:
            Ricardo Goulart
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: