Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-16432

eZ Teamroom / Manual tests | tc-152:Test members

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Medium Medium
    • Resolution: Obsolete
    • Affects Version/s: 4.3.0beta2
    • Fix Version/s: QA tracked issues
    • Labels:
      None
    • Environment:

      Operating System: Linux
      PHP Version: 5.2
      Database and version:
      Browser (and version): Firefox 3.6

      Description

      In > "Manage Members" > "Teamroom policy management" > The table is miss formatted
      

      Steps to reproduce

      Setup
       
         1. Access the teamroom siteaccess of your eZ Publish installation
         2. Login as admin
         3. On the ezteamroom frontpage click on Create new teamroom
            Enter the information:
            Name: Teamroom 1
            Access: Private
            Click on Store teamroom
       
      Verify that inviting a member in a teamroom works (with creating account)
       
         1. Go to the frontpage
         2. Click on "Teamroom 1" under the second icon from the left
         3. Click on Invite new member
         4. Enter an email address (which is not used yet for an account on the eZ Publish installation)
         5. Click on the Search user button
         6. Click on the Send invitation button
         7. Verify the email address account for the received confirmation mail
         8. Click on the link in the confirmation mail
         9. Verify that you get the message "Account activated"
        10. LOGOUT AND LOGIN with the admin account in ezteamroom (BUG?)
        11. Go to "Teamroom 1" -> Manage member
        12. Verify that the new account created for the email address entered above is in the list
       
      Verify that removing a member from a teamroom works
       
         1. Go to the frontpage
         2. Click on "Teamroom 1" under the second icon from the left
         3. Click on Manage member
         4. Select the user created by email address in the previous test
         5. Click on the button Remove user
         6. Verify that you get a mail about the account being terminated
       
      Verify that inviting a member in a teamroom works (without creating account)
       
         1. Go to the frontpage
         2. Click on "Teamroom 1" under the second icon from the left
         3. Click on Invite new member
         4. Enter the same email address as in the previous test
         5. Click on the Search user button
         6. Verify that you get the message "User was successfully added: New invited user <email address>"
         7. Verify the email address account
         8. Verify that the mail doesn't contain a confirmation link
         9. Go to "Teamroom 1" -> Manage member
        10. Verify that the new account created for the email address entered above is in the list
      
      

        Activity

        ezrobot added a comment -

        This issue has been automatically closed due to the lack of activity over a long period of time. It is very likely that it is obsolete, but if you think it is still valid, do not hesitate to reopen it and mention why.


          People

          • Assignee:
            unknown
            Reporter:
            Ricardo Goulart
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated: