Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-15933

StyleEditor: Some properties values are lost during changing of other styles

    Details

      Description

      I have had problems that property values you enter are lost when you add other properties. This has for instance happend when I selected a font color using the palette. and then for instance afterwards have added a new property (like text-align). Then the input field for the color is cleared. However, this I have not been able to reproduce at will

      I have however found a reproducable case in regards to borders

      Steps to reproduce

      Setup
         1. Log in as admin in ezwebin
         2. View some article
         4. Click "CSS" button in toolbar
       
      Test boder-top-color
         1. Click "Path" elements in the top right corner of the page ("Home / News / Test article" )
         2. Select Border -> border in drop down
         3. Click "Add" button
         4. Write "solid" in the border input field
         5. Click "Apply" button
         6. Select Border -> border-top-color in drop down
         7. Click "Add" button
         8. Validate that that border type still is "solid"
         9. Select some green color using the color palette
        10. Click "Save" button
        11. Validate that you get a border around the path element. The top border should be green, the rest should be black
      

      Step #8 will fail above. The input filed will instead be empty

        Issue Links

          Activity

          Hide
          Vidar Langseid added a comment -

          The testcase provided in #015938 seems also to be able to reproduce this issue (however, sometimes it works as expected....)

          Show
          Vidar Langseid added a comment - The testcase provided in #015938 seems also to be able to reproduce this issue (however, sometimes it works as expected....)
          Hide
          Łukasz Serwatka added a comment -

          Fixed in trunk.

          Show
          Łukasz Serwatka added a comment - Fixed in trunk.
          Hide
          Vidar Langseid added a comment -

          Yes, seems to work now

          Show
          Vidar Langseid added a comment - Yes, seems to work now
          Hide
          ezrobot added a comment -

          This issue has been automatically closed due to the lack of activity over a long period of time. It is very likely that it is obsolete, but if you think it is still valid, do not hesitate to reopen it and mention why.

          Show
          ezrobot added a comment - This issue has been automatically closed due to the lack of activity over a long period of time. It is very likely that it is obsolete, but if you think it is still valid, do not hesitate to reopen it and mention why.

            People

            • Assignee:
              Łukasz Serwatka
              Reporter:
              Vidar Langseid
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: