Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-10065

Selecting location in view control window for version preview in Administration Interface does not work correctly

    XMLWordPrintable

    Details

      Description

      For content objects with multiple locations, the location list in the view control window (version preview) misbehaves:
      1. none of the radio buttons in the location list is checked when the page is first displayed, this is however the case for siteaccess.

      2. when selecting a radion button (and updating view) this does not affect the actual preview. For example, the breadcrumbs path remains teh same whatever location you select.

      3. when selecting a radio button and updating the view, no radio button in the location list is selected.

      In other words, it seems like clicking the "Update view" button does not capture that the user has selected a location, and the view control window does not display which location is selected when multiple locations exist.

      Steps to reproduce

      Add a secondary location to a random object of ezwebin demo-content. Bring up version preview for some version of that object and examine the view control window. Try selecting the secondary location and update view.

        Attachments

          Activity

            People

            Assignee:
            unknown unknown
            Reporter:
            bms Bergfrid Skaara
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated: