Uploaded image for project: 'eZ Platform Enterprise Edition'
  1. eZ Platform Enterprise Edition
  2. EZEE-2572

Page Builder doesn't work with Map\Host matcher when SiteAccesses are configured for different domains

    XMLWordPrintable

    Details

    • Sprint:
      [2.5] - Sprint 4

      Description

      Currently when the Page Builder doesn't show page under SiteAccesses which are matched using Map\Host matcher.

      Steps to reproduce:
      1. Create a eZ Platform v2.3 installation.
      2. Apply provided SiteAccesses configuration:

      ezplatform.yml
      siteaccess:
          list: [site, admin, eng, pol]
              groups:
                  site_group: [site, eng, pol]
      
                  # WARNING: Do not remove or rename this group.
                  # It's used to distinguish common siteaccesses from admin ones.
                  # In case of multisite with multiple admin panels, remember to add any additional admin siteaccess to this group.
                  admin_group: [admin]
              default_siteaccess: site
              match:
      #            URIElement: 1
                  Map\Host:
                      english.a.test: eng
                      polish.b.test: pol
                      admin.c.test: admin
      admin_group:
          page_builder:
              siteaccess_list: [site, eng, pol]
      

      3. Log in to the Back Office and try to preview a site under eng or pol SiteAccess.

      Result:
      User is presented with the following eror:

      Parameter 'content' is not set.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              konrad.oboza@ez.no Konrad Oboza
              Votes:
              1 Vote for this issue
              Watchers:
              8 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: