Uploaded image for project: 'eZ Platform Enterprise Edition'
  1. eZ Platform Enterprise Edition
  2. EZEE-1324

"Cannot read property '_href' of undefined" error generated when accessing a content in a language not specified in the .yml settings

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: 1.7.0
    • Fix Version/s: Customer request, 1.7.1
    • Component/s: Studio UI
    • Labels:
      None

      Description

      Steps to reproduce:

      • Prepare a test eZ Studio installation (studio-clean), clean. For issue reproduction purposes, no settings change is required, just use the default;
      • Login to the admin interface, go to Admin Panel/Languages, and create a new language e.g. "en";
      • Do not add the new language to the app/config/ezplatform.yml configurations;
      • Go to Content/Content structure, and create a new article in the new language;
      • Publish. The article is published, but a "Cannot read property '_href' of undefined" error message is displayed at the bottom.

      Note: that error message is displayed every time the content is accessed in the content tree.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              nuno.oliveira-obsolete@ez.no Nuno Oliveira (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: