Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-6971

Can not translate options when addtion an option datatype class attribute

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Medium Medium
    • Resolution: Duplicate
    • Affects Version/s: 3.6.1
    • Fix Version/s: None
    • Labels:
      None
    • Environment:

      Version: 3.6.1, trunk
      PHP Version: 3.1
      Webserver: apach
      Database: mysql

      Description

      When I create a new class, and add a selection datatype, i have to add options within the class definition (http://ez.no/doc/ez_publish/technical_manual/3_6/reference/datatypes/option)

      I can only add these options in one language and there is no way for me to translate them to other languages.

      The "Disable translation" checkbox is not relevant here, since there is no user interface to translate.

      when an instance of this object is created, the options given are those added when the class was created.

        Issue Links

          Activity

          Disabled User added a comment -


          Confirmed.

          noam s added a comment -

          This is a bug in the translation system.

          Unless options in a selection datatype are translatable, ez sites are not multi-lingual : options withing objects can only be presented in the main language and not in the languages of the other translations.

          Valentin Doroschuk added a comment -

          This is a feature enhancement. Together with the translation of all the other class elementens, like names.

          noam s added a comment -

          when you add values into the selection datatype - these values are part of the CONTENT of the object.

          if you can not translate the CONTENT then you have a problem with keeping you data multi-lingual.

          what you are talking about is class attribute names which can not be translated right now - but are part of the STRUCTURE and have no impact on the data stored. you can manualy change the templates to translate class names, but you can not do so with content.

          noam s added a comment -

          ...i have noticed that you have classified this bug under: "eZ publish - administration interface" - but this has to do with the content and not the interface

          André R added a comment -
          Geir Arne Waaler added a comment -

          I move this from Code Review to Closed since it has been solved in another issue.

          Geir Arne Waaler
          eZ Documentation

          ezrobot added a comment -

          This issue has been automatically closed due to the lack of activity over a long period of time. It is very likely that it is obsolete, but if you think it is still valid, do not hesitate to reopen it and mention why.


            People

            • Assignee:
              André R
              Reporter:
              noam s
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: