Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-4496

Contextual help on content classes for users

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Low Low
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Misc
    • Labels:
      None
    • Environment:

      Version: 3.4
      PHP Version:
      Webserver:
      Database:

      Description

      When a site designer sets up new content classes, it is difficult to communicate to the content administrator and content editors how that content will appear on the site. Users who are updating or adding content are presented with a "Summary" field but they do not realize that the summary appears in folder listings, before the details in the full view, and in search results.

      If the content classes had a "help" or "tip" for each datatype, designers could put some contextual help in each content class, allowing users a better understanding of how the content that they are typing in to a web-based admin form will be used on the site.

      For sites with one or two admins, this is not necessary. But clearly, eZ is meant to accommodate larger sites and organizations in which such a feature would significantly reduce the training burden and improve content quality.

        Issue Links

          Activity

          Mark Marsiglio created issue -
          Paul Borgermans added a comment -

          Right now, I have to resort to custom edit templates for the most important classes. But it may not be so simple for the case of multi-language sites.

          André R added a comment -
          ezrobot added a comment -

          This issue has been automatically closed due to the lack of activity over a long period of time. It is very likely that it is obsolete, but if you think it is still valid, do not hesitate to reopen it and mention why.

          André Rømcke made changes -
          Field Original Value New Value
          Workflow eZ Community Workflow [ 23618 ] eZ Engineering Scrumban Workflow [ 40786 ]
          André Rømcke made changes -
          Workflow eZ Engineering Scrumban Workflow [ 40786 ] EZ* Development Workflow [ 75234 ]
          Alex Schuster made changes -
          Workflow EZ* Development Workflow [ 75234 ] EZEE Development Workflow [ 113811 ]

            People

            • Assignee:
              unknown
              Reporter:
              Mark Marsiglio
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: