Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-30509

Location visibility check breaks limitation of Content/Read

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: High High
    • Resolution: Fixed
    • Affects Version/s: 2.5.1
    • Fix Version/s: Customer request, 2.5.2
    • Component/s: None
    • Labels:

      Description

      Content/Read limitation by Location prevents the user from accessing the /admin page - the system checks the root location which can't be limited.

      Current state:
      After trying to access /admin page, the exception is thrown:

      User does not have access to 'read' 'content' with: locationId '1'
      

      Expected:
      User is able to access the /admin page.

      Steps to reproduce:
      > Clean eZ Platform v2.5.1 installation
      > Add Role Foo
      > Assign policies to the role:

      • User/Login SiteAccess: Admin
      • Content/Read Location: /eZ Platform

      > Create new user and assign him to the Foo role
      > Login as the new user
      The exception should appear after redirection to the /admin page.

      This is caused by ezsystems/ezplatform-admin-ui/src/bundle/Controller/ContentViewController:supplyIsLocationInvisible which (in some cases) loads root's parentLocation.

        Issue Links

          Activity

          Barbara Grajczyk added a comment -
          Barbara Grajczyk added a comment -

            People

            • Assignee:
              Unassigned
              Reporter:
              Marcin Czech
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: