Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-30289

Content Tree does not load when root location has no items

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: High High
    • Resolution: Fixed
    • Affects Version/s: 2.5.0-rc1
    • Fix Version/s: 2.5.0-rc2
    • Component/s: None
    • Labels:

      Description

      After creating an item the subitems list does not display any items.

      Steps to reproduce:
      1. Login as admin
      2. Go to Content -> Content Structure
      3. Create a new Folder
      4. Publish it

      Expected:
      Subitems list is correctly loaded

      Actual:
      Subitems list table is not loaded.

      Error in console:

      VM21:37 TypeError: Cannot read property 'children' of undefined
          at ContentTreeModule.clipTooDeepSubtreeBranches (content.tree.module.js:296)
          at new ContentTreeModule (content.tree.module.js:65)
          at Yf (react-dom.production.min.js:67)
          at qg (react-dom.production.min.js:92)
          at hi (react-dom.production.min.js:104)
          at Qg (react-dom.production.min.js:144)
          at Rg (react-dom.production.min.js:145)
          at Sc (react-dom.production.min.js:158)
          at Z (react-dom.production.min.js:156)
       
      react-dom.production.min.js:157 Uncaught TypeError: Cannot read property 'children' of undefined
          at ContentTreeModule.clipTooDeepSubtreeBranches (content.tree.module.js:296)
          at new ContentTreeModule (content.tree.module.js:65)
          at Yf (react-dom.production.min.js:67)
          at qg (react-dom.production.min.js:92)
          at hi (react-dom.production.min.js:104)
          at Qg (react-dom.production.min.js:144)
          at Rg (react-dom.production.min.js:145)
          at Sc (react-dom.production.min.js:158)
          at Z (react-dom.production.min.js:156)
          at Kc (react-dom.production.min.js:155)
      

        Activity

        Jakub Brzegowski added a comment -

        https://jira.ez.no/browse/EZP-30299 is probably duplicate of this ticket.


          People

          • Assignee:
            Unassigned
            Reporter:
            Marek Nocoń
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: