Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-29839

ReindexCommand should allow to use selected user

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: High High
    • Resolution: Invalid
    • Affects Version/s: 1.7.8, 1.13.4, 2.2.3, 2.3.2
    • Fix Version/s: Customer request
    • Component/s: Search
    • Labels:
      None

      Description

      The customer reported that ReindexCommand is always using anonymous user for processing the contents what might not be the best idea in cases of restricted permissions for anonymous. Therefore, the command should allow to pick particular user for execution.

        Activity

        Kamil Madejski created issue -
        Kamil Madejski made changes -
        Field Original Value New Value
        Status Open [ 1 ] Confirmed [ 10037 ]
        Kamil Madejski made changes -
        Status Confirmed [ 10037 ] InputQ [ 10001 ]
        Kamil Madejski made changes -
        Link This issue relates to CS-7164 [ CS-7164 ]
        Kamil Madejski made changes -
        Assignee Kamil Madejski [ kamil.madejski@ez.no ]
        Kamil Madejski made changes -
        Status InputQ [ 10001 ] Development [ 3 ]
        Kamil Madejski made changes -
        Status Development [ 3 ] Development Review [ 10006 ]
        Michał Szołtysek made changes -
        Status Development Review [ 10006 ] Documentation Review done [ 10011 ]
        Assignee Kamil Madejski [ kamil.madejski@ez.no ]
        Michał Szołtysek made changes -
        Status Documentation Review done [ 10011 ] QA [ 10008 ]
        Kamil Madejski made changes -
        Assignee Michał Szołtysek [ michal.szoltysek@ez.no ] Kamil Madejski [ kamil.madejski@ez.no ]
        Michał Szołtysek made changes -
        Status QA [ 10008 ] InputQ [ 10001 ]
        Assignee Kamil Madejski [ kamil.madejski@ez.no ]
        Kamil Madejski added a comment -

        The issue is caused by the customer's custom code, therefore I'm closing this ticket as invalid.

        Kamil Madejski made changes -
        Status InputQ [ 10001 ] Closed [ 6 ]
        Resolution Invalid [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Confirmed Confirmed
        1m 11s 1 Kamil Madejski 27/Nov/18 4:01 PM
        Confirmed Confirmed InputQ InputQ
        8s 1 Kamil Madejski 27/Nov/18 4:01 PM
        InputQ InputQ Development Development
        29m 14s 1 Kamil Madejski 27/Nov/18 4:31 PM
        Development Development Development Review Development Review
        3s 1 Kamil Madejski 27/Nov/18 4:31 PM
        Development Review Development Review Documentation Review done Documentation Review done
        1d 17h 18m 1 Michał Szołtysek 29/Nov/18 9:49 AM
        Documentation Review done Documentation Review done QA QA
        10s 1 Michał Szołtysek 29/Nov/18 9:49 AM
        QA QA InputQ InputQ
        4d 22h 44m 1 Michał Szołtysek 04/Dec/18 8:34 AM
        InputQ InputQ Closed Closed
        6d 1h 44m 1 Kamil Madejski 10/Dec/18 10:19 AM

          People

          • Assignee:
            Unassigned
            Reporter:
            Kamil Madejski
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: