Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-29489

Error 500 when accessing content which has relation to content in trash

    Details

      Description

      Customer observed an issue with policies when accessing content which has relation in trash.

      Steps to reproduce:
      1. Edit existing Content Type (e.g. Article) and add ezobjectrelationlist.
      2. Create a new Article1.
      3. Create Article2 and set relation to Article1.
      4. Send Article1 to Trash.
      5. Create a new User-Editor.
      6. Log in as Editor and try to access Article2.

      Result:
      The Exception is thrown:

      An exception has been thrown during the rendering of a template ("User does not have access to 'read' 'content' with: contentId '60''") in "@EzPlatformAdminUi/fieldtypes/preview/content_fields.html.twig".
      

        Issue Links

          Activity

          Konrad Oboza created issue -
          Konrad Oboza made changes -
          Field Original Value New Value
          Status Open [ 1 ] Confirmed [ 10037 ]
          Konrad Oboza made changes -
          Status Confirmed [ 10037 ] InputQ [ 10001 ]
          Konrad Oboza made changes -
          Link This issue relates to CS-6910 [ CS-6910 ]
          Barbara Grajczyk added a comment - - edited

          It is connected with Role Assignments, because Editor has got some limitations: subtree of Location /eZ Platform and /Media.

          Konrad Oboza made changes -
          Status InputQ [ 10001 ] Development [ 3 ]
          Assignee Konrad Oboza [ konrad.oboza@ez.no ]
          Konrad Oboza made changes -
          Status Development [ 3 ] Development Review [ 10006 ]
          Konrad Oboza made changes -
          Assignee Konrad Oboza [ konrad.oboza@ez.no ] André Rømcke [ andre.romcke@ez.no ]
          André Rømcke made changes -
          Link This issue relates to EZP-29474 [ EZP-29474 ]
          André Rømcke made changes -
          Status Development Review [ 10006 ] Documentation Review done [ 10011 ]
          Affects Version/s 1.13.4 [ 14992 ]
          Affects Version/s 1.7.8 [ 14923 ]
          Fix Version/s 2.3.0-rc1 [ 14909 ]
          Fix Version/s 1.7.9 [ 15015 ]
          Fix Version/s 1.13.5 [ 15016 ]
          Assignee André Rømcke [ andre.romcke@ez.no ]
          André Rømcke made changes -
          Fix Version/s 2.3.0-beta1 [ 14908 ]
          Fix Version/s 2.3.0-rc1 [ 14909 ]
          Barbara Grajczyk made changes -
          Assignee Barbara Grajczyk [ barbara.grajczyk@ez.no ]
          Barbara Grajczyk made changes -
          Status Documentation Review done [ 10011 ] QA [ 10008 ]
          Barbara Grajczyk made changes -
          Assignee Barbara Grajczyk [ barbara.grajczyk@ez.no ]
          Status QA [ 10008 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Confirmed Confirmed
          2m 15s 1 Konrad Oboza 01/Aug/18 3:52 PM
          Confirmed Confirmed InputQ InputQ
          4s 1 Konrad Oboza 01/Aug/18 3:52 PM
          InputQ InputQ Development Development
          34d 19h 26m 1 Konrad Oboza 05/Sep/18 11:19 AM
          Development Development Development Review Development Review
          3s 1 Konrad Oboza 05/Sep/18 11:19 AM
          Development Review Development Review Documentation Review done Documentation Review done
          4d 17h 50m 1 André Rømcke 10/Sep/18 5:09 AM
          Documentation Review done Documentation Review done QA QA
          2d 8h 21m 1 Barbara Grajczyk 12/Sep/18 1:31 PM
          QA QA Closed Closed
          82d 3h 6m 1 Barbara Grajczyk 03/Dec/18 3:37 PM

            People

            • Assignee:
              Unassigned
              Reporter:
              Konrad Oboza
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: