Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-29350

Upgrade script not working due to MySQL 5.7 strict mode

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: High High
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2018.06, 2017.12.3
    • Component/s: None
    • Labels:
      None

      Description

      MySQL 5.7 is strict by default and will error out on the incorrect GROUP BY used in `update/common/scripts/5.4/cleanuntranslatablerelations.php`.

      Pull reqest: https://github.com/ezsystems/ezpublish-legacy/pull/1368

        Activity

        Ole Morten Halvorsen created issue -
        Ole Morten Halvorsen made changes -
        Field Original Value New Value
        Description MySQL 5.7 is strict by default and will error out on the incorrect GROUP BY used in `update/common/scripts/5.4/cleanuntranslatablerelations.php`. MySQL 5.7 is strict by default and will error out on the incorrect GROUP BY used in `update/common/scripts/5.4/cleanuntranslatablerelations.php`.

        Pull reqest: https://github.com/ezsystems/ezpublish-legacy/pull/1368
        André Rømcke made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Fix Version/s 2017.12.3 [ 15008 ]
        Fix Version/s 2018.06 [ 14890 ]
        Resolution Fixed [ 1 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        13d 21h 51m 1 André Rømcke 12/Jul/18 1:11 PM

          People

          • Assignee:
            Unassigned
            Reporter:
            Ole Morten Halvorsen
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: