Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-29269

User draft is not discarded on edition cancel

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: High High
    • Resolution: Done
    • Affects Version/s: 2.1.0
    • Fix Version/s: Customer request
    • Component/s: None
    • Labels:
      None

      Description

      Steps to reproduce

      1. Login to administration panel
      2. Go to Users tab
      3. Pick any user account and edit it
      4. On edit view click Cancel
      5. Try to edit previously edited user once again

      Result
      You will see Draft conflict when editing window.

      Expected result
      User draft should be removed automatically on edition cancel.

        Activity

        Andrzej Longosz added a comment -

        Expected result
        User draft should be removed automatically on edition cancel.

        Actually, since User has its own UserService wrapper, the need for deleting draft should never happen. Instead of editing it like a normal Content, it should have been dedicated action, since UserService::updateUser creates draft and then publishes it at once.

        Dawid Parafiński added a comment -

        Maciej Tyrała
        Kamil Madejski
        I just attached patch for adminUI for 1.2 version. Please test it to make sure everything is alright.


          People

          • Assignee:
            Unassigned
            Reporter:
            Kamil Madejski
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: