Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-29254

Images embedded in RichText editor dissapear after undo

    Details

    • Sprint:
      [2.3] Sprint 3

      Description

      Customer encountered problems with RichText editor. After undoing some changes (using Ctrl+Z / Cmd+Z) all the images which were embedded using UDW disappear.

      Steps to reproduce:
      1. Create new content which contains RichText field, e.g. Article.
      2. Type some text.
      3. Attach an image using embed or image widget.
      4. Hit "undo" keys combination: Ctrl+Z / Cmd+Z.

      Result:
      A small rectangle is shown instead of an image (see attachment).

      Note 1:
      This issue applies only to content which was embedded using UDW (either existing one from the library, or a new one which was uploaded using "Create" tab). Problem doesn't show up when attaching image via drag&drop.

      Note 2:
      In v2 behaviour is a bit odd: images disappear, the small rectangle shows up but immediately after that images appear once again.

      Note 3:
      After publishing the article, images are renderred correctly.

      1. EZP-29254.patch
        10 kB
        Dariusz Szut
      1. image_after_undo.png
        9 kB

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            Unassigned
            Reporter:
            Konrad Oboza
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Agile