Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-29091

Publishing Content from the frontend results in error

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: High High
    • Resolution: Fixed
    • Affects Version/s: 2.1.0, 2.2.1
    • Fix Version/s: 2.2.1
    • Labels:
      None

      Description

      When user is redirected after creating Content on the frontend he encounters an error (which did not happen in v1).

      Steps to reproduce:
      1. Go to yoursite.com/login
      2. Login as admin
      3. Go to yoursite.com/content/create/nodraft/folder/eng-GB/2
      4. Fill the form and send it

      Expected:
      I'm redirected to view mode of the Content (on frontend) and I can see the Content.

      Actual:
      User is redirected, but error occurs:
      Route is not allowed in current siteaccess

        Activity

        Marek Nocoń added a comment -

        It's tested by this scenario: https://github.com/ezsystems/repository-forms/blob/master/features/ContentEdit/create_without_draft.feature#L6
        which should be passing on Travis when the issue is fixed.


          People

          • Assignee:
            Unassigned
            Reporter:
            Marek Nocoń
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: