Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-28993

Varnish cache is not updated after modifying Content

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: High High
    • Resolution: Fixed
    • Affects Version/s: 2.1.0-rc1
    • Fix Version/s: 2.1.0
    • Component/s: Platform > HTTPCache
    • Labels:
      None
    • Environment:

      Varnish 5

      Description

      Frontend cache is not updated after Content is modified in the admin panel.

      Requirements:
      Working Varnish setup.

      Steps to reproduce:
      1. Login as admin
      2. Create an Article and publish it
      3. Visit the Article on the frontend (keep this tab open)
      4. Go back to the back office and modify any field in created Article
      5. Refresh tab opened previously

      Expected:
      Changes made to Content are visible

      Actual:
      Old version of Content is still displayed

        Issue Links

          Activity

          Bertrand Dunogier added a comment -

          Sylvain has extra information in EZP-28995.

          Sylvain Guittard added a comment -

          Thanks Kamil Madejski but I am afraid that it's not enough.
          FYI, Sébastien Morel tried the patch on his instance. The bug is still there.
          I also updated my instance on platform.sh and the bug is still there.
          (cf. EZP-28995)

          André Rømcke added a comment - - edited

          Dear reporters (Sylvain Guittard, Sébastien Morel)

          we are in need of more information, preferably within the next hour or so given the urgency of this issue, before we can effectively figure out what is wrong. Otherwise this will become a second guessing game, amplified into a ping-pong game by timezone differences.

          1. Can you reproduce locally or not, using Symfony Proxy? If not then issue on platform.sh might be in regards to changes done on platform.sh config, ref: https://github.com/ezsystems/ezplatform/pull/276

          2. The Varnish issue: With the exact same Varnish setup, was it working with 2.0? Or did the Varnish setup slightly change? Asking, because we are aware the Host header sent on purge might be wrong, so if Varnish is setup on a port other then 80 it might ignore the purges. Way to see this is by debugging purge requests and see that they all return info that 0 items where purged. But it's been like this since 1.12: Ref: https://github.com/ezsystems/ezplatform-http-cache/blame/master/src/PurgeClient/VarnishPurgeClient.php#L44-L47

          If none of those are at relevant, then there might be another regression besides the one we just fixed in the kernel change which removes about 5000 lines of code, so this is where we will likely look further for possible clues to what might be wrong here: https://github.com/ezsystems/ezpublish-kernel/pull/2194 Unless we by chance gets QA to reproduce any of this.

          EDIT: Fix below can potentially explain it, assuming both of you where testing with eZ Platform EE, as the problem below was not affecting eZ Platform. Please verify as soon as you can.

          Sylvain Guittard added a comment -

          Thanks André Rømcke and Kamil Madejski for working on this.
          I will have a closer look to the configuration on platform.sh.
          What I can say so far: as mentioned on the other ticket EZP-28995, the bug was not on eZ Platform EE.

          Sylvain Guittard added a comment -

          Marek Nocoń: Can we close this ticket?

          Marek Nocoń added a comment -

          Sylvain Guittard not yet, I still have to check the fix that Kamil prepared for v1 (1.13)
          (https://github.com/ezsystems/ezplatform-http-cache-fastly/releases/tag/v1.0.1.2)

          Marek Nocoń added a comment -

          Tested on ezplatform-ee 1.13.1 with ezplatform-ee-http-cache-fastly 1.0.1.2, looks good


            People

            • Assignee:
              Unassigned
              Reporter:
              Marek Nocoń
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: