Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-28100

As a user I can follow the bike tutorial without errors

    XMLWordPrintable

    Details

    • Sprint:
      [2.1] Sprint 3
    • Story Points:
      1

      Description

      Feedback from users trying the Bike tutorial which make following the tutorial unwieldy and complex:

      1. To log in to Admin Panel the user had to add "always_populate_raw_post_data = -1" to php.ini. This may be an individual problem, not everyone encounters it.
      2. https://doc.ezplatform.com/en/1.7/getting_started/install_using_composer/ says to set SYMFONY_ENV="prod", and https://doc.ezplatform.com/en/1.7/getting_started/install_manually/ says to set it to dev, while assetic is set to "prod" not "dev"
      3. The tutorial doesn't say what the user should do after creating a new Content item in step 2 - Save or Publish? This is not obvious for someone who doesn't know the product.
      4. Step 3 does not explicitly say that the user should change the src of images other than 128_bike_white_avenir.png and logo_just_letters.png, but the user had to change all src's for all Rides. This is not needed in the long run, because we remove it in the next step, but it should be explained, otherwise the user can have doubts.
      5. After adding new assets it wasn't enough to add the files and refresh the pages, the user also had to call `app/console assetic:dump` every time, this was not mentioned in the text.
      6. When working with Twig templates we have a command:
      Edit root_folder.html.twig and replace the whole content of the file with the following code:

      <!--root\_folder.html.twig-->
      {% extends "pagelayout.html.twig" %}
      {% block content %}
      <h3 class="center bottom-plus new-header">{{ ez_content_name(content) }}</h3>
      <div class="col-xs-10 text-justified">{{ ez_render_field(content, 'description') }}</div>
      {% endblock %}
      

      As a result we get an error:
      A template that extends another one cannot include contents outside Twig blocks. Did you forget to put the contents inside a

      {% block %}

      tag?
      The correct code would be:

      {% extends "pagelayout.html.twig" %}
      {% block content %}
      <!--root\_folder.html.twig-->
      <h3 class="center bottom-plus new-header">{{ ez_content_name(content) }}</h3>
      <div class="col-xs-10 text-justified">{{ ez_render_field(content, 'description') }}</div>
      {% endblock %}
      

      It seems that comments in the first line of Twig code break displaying, like here: https://doc.ezplatform.com/en/1.7/tutorials/platform_beginner/4_displaying_content_of_a_ride/#creating-the-ride-view

      7. There are two identical images in https://doc.ezplatform.com/en/1.7/tutorials/platform_beginner/2_creating_your_content_model/#populate-your-content-tree
      8. UI terminology should be updated to current naming (Content tree -> Content Browse etc.)
      9. https://doc.ezplatform.com/en/1.7/tutorials/platform_beginner/5_displaying_the_list_of_rides_on_the_homepage/#customize-your-homepage-template doesn't say where in the file the code should be placed
      10. https://doc.ezplatform.com/en/1.7/tutorials/platform_beginner/4_displaying_content_of_a_ride/#add-a-new-parameter-to-your-override-rule is not clear that the config should be added to the existing keys, not replace them.
      11. There is still some problem with https://doc.ezplatform.com/en/1.7/tutorials/platform_beginner/3_customizing_the_general_layout/#fixing-the-assets. Some users don't have the permissions to access the assets folder, and after fixing, they have to fix paths to assets, like:
      `<img src="assets/images/geneva.png" style="width: 100%;">`
      12. https://doc.ezplatform.com/en/1.7/tutorials/platform_beginner/5_displaying_the_list_of_rides_on_the_homepage/#customize-your-homepage-template path seems to be invalid, probably there should be: 'Resources/views/full/root_folder.html.twig' (without content).
      13. https://doc.ezplatform.com/en/1.7/tutorials/platform_beginner/5_displaying_the_list_of_rides_on_the_homepage/#use-a-custom-template-to-display-view-line-of-a-ride doesn't say where in the file the code should be placed (ezplatform.yml)

      Note: Other feedback is already reported in

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              dominika.kurek@ez.no Dominika Kurek
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: