Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-27746

Port of Obsolete object relations not cleaned up

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: High High
    • Resolution: Fixed
    • Affects Version/s: 2014.11
    • Fix Version/s: 2017.08-rc1
    • Component/s: Legacy stack
    • Labels:
      None

      Description

      This is a port of EZP-25396 and related later fixes from 5.4 to master/2017.08.

      When editing and publishing new object version with relation fields, the old (obsolete) relations are not cleared.

      Steps to reproduce
      • Pre-condition: ContentType with relation list field.
      • Create a new "Test" content (in eng-GB), add relation to object "A", publish.
      • (optional: add a new version in a different language, relate to object "B", publish).
      • Add a new version in the main language (eng-GB), modify the relation to use object "A2", publish.
      Expected result:

      In object's "relations" tab, it should only show "A2" and "B",

      Actual result:

      In object's "relations" tab, objects "A", "A2" and "B" are shown.

      Further Notes:

      The behavior seems a regression caused by EZP-24530

        Issue Links

          Activity


            People

            • Assignee:
              Unassigned
              Reporter:
              André Rømcke
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: