Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: High High
    • Resolution: Fixed
    • Affects Version/s: 1.8.0
    • Fix Version/s: QA tracked issues
    • Component/s: Install
    • Labels:
      None
    • Environment:

      Debian 8
      PHP 5.6.17
      mysql Ver 14.14 Distrib 5.5.47

      Description

      Trying to install platform master, by using:
      php -d memory_limit=-1 composer.phar create-project --prefer-dist --keep-vcs --no-dev ezsystems/ezplatform ezpmaster 'dev-master'
      at the end, after the assetic dump, I get the following error:

      > Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installRequirementsFile
      Could not open input file: dump-autoload
      Script @composer dump-autoload --optimize handling the post-create-project-cmd event returned with error code 1
      

      Note: the installation seems usable afterwards, but the error itself may have had unpredicted results and consequences and deem the installation untrustworthy to use.

        Activity

        Hide
        Paulo Nunes (Inactive) added a comment - - edited

        I'm having the same results as Rui but only when using composer.phar. If I use composer globally installed, the issue doesn't happen

        composer create-project --prefer-dist --keep-vcs --no-dev ezsystems/ezplatform ezpmaster 'dev-master' -> don't happen

        php -d memory_limit=-1 composer.phar create-project --prefer-dist --keep-vcs --no-dev ezsystems/ezplatform ezpmaster 'dev-master' -> the issue happens

        Working on a
        Operating System: Debian 8
        PHP Version: 5.6.14-0+deb8u1
        Database and version: Mysql 5.5.46-0+deb8u1
        Composer version 1.3.1 2017-01-07 18:08:51

        Edit:
        Same happens when using ubuntu 16.04, with php 7.0

        Show
        Paulo Nunes (Inactive) added a comment - - edited I'm having the same results as Rui but only when using composer.phar . If I use composer globally installed, the issue doesn't happen composer create-project --prefer-dist --keep-vcs --no-dev ezsystems/ezplatform ezpmaster 'dev-master' -> don't happen php -d memory_limit=-1 composer.phar create-project --prefer-dist --keep-vcs --no-dev ezsystems/ezplatform ezpmaster 'dev-master' -> the issue happens Working on a Operating System: Debian 8 PHP Version: 5.6.14-0+deb8u1 Database and version: Mysql 5.5.46-0+deb8u1 Composer version 1.3.1 2017-01-07 18:08:51 Edit: Same happens when using ubuntu 16.04, with php 7.0
        Hide
        André Rømcke added a comment -

        Reported to composer tracker: https://github.com/composer/composer/issues/6080

        If it's not fixed we should revert the change in 1.7 and master before 1.7.1-rc1.

        Show
        André Rømcke added a comment - Reported to composer tracker: https://github.com/composer/composer/issues/6080 If it's not fixed we should revert the change in 1.7 and master before 1.7.1-rc1.
        Hide
        André Rømcke added a comment - - edited

        Fixed in https://github.com/ezsystems/ezplatform/commit/bb2a3135ba5050143db82efb39aff3f20d2884e8

        merged to platform-demo, studio and studio-demo.

        Note: The error is not in anyway affecting the install and avoiding you from using it, so I renamed the issue. The only downside was that autoload was not dumped, which is a optimization step and just means the improved performance it gives was missing, this is however also covered by doc already and will be made more prominent there.

        Show
        André Rømcke added a comment - - edited Fixed in https://github.com/ezsystems/ezplatform/commit/bb2a3135ba5050143db82efb39aff3f20d2884e8 merged to platform-demo, studio and studio-demo. Note: The error is not in anyway affecting the install and avoiding you from using it, so I renamed the issue. The only downside was that autoload was not dumped, which is a optimization step and just means the improved performance it gives was missing, this is however also covered by doc already and will be made more prominent there.
        Hide
        Paulo Nunes (Inactive) added a comment -

        Verified by QA.

        Tested with composer.phar e global composer.
        The error no longer happens

        Show
        Paulo Nunes (Inactive) added a comment - Verified by QA. Tested with composer.phar e global composer. The error no longer happens

          People

          • Assignee:
            Unassigned
            Reporter:
            Rui Silva (Inactive)
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: