Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-26373

Multiupload not working in Firefox when using HTTPS

    XMLWordPrintable

    Details

      Description

      When using HTTPS, multiupload does not work in Firefox. It is possible to select files, and eZ Publish will indicate it is uploading the first file, but the upload isn't actually happening - see attached "ez_support_issue_5735_screenshot_1.png" screenshot.

      This seems to affect Firefox specifically, as multiupload works fine in IE, Edge and Chrome. No errors are generated in the eZ Publish logs (legacy & symfony) or in the browser JS console. There's nothing relevant in the apache logs, either.

      Steps to reproduce:

      1. Prepare a test eZ Publish 5.4 installation, fully updated via composer;
      2. Set it up in DFS cluster mode + Memcache;
      3. Generate all necessary SSL certificates;
      4. Using the latest Firefox version (currently 49), log in to the admin interface in HTTPS e.g. https://example.com/ezdemo_site_admin/;
      5. On the "Content structure" section, click on a suitable content (used a test folder), and then click on "Upload multiple files";
      6. Select a few test files (images, *.txt, etc) and try to upload them. The progress bar for the first file stays frozen, and nothing happens beyond that.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              nuno.oliveira-obsolete@ez.no Nuno Oliveira (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: