Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-26174

Creating next users fail after created a new user with v.1.4.0

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Invalid
    • Affects Version/s: 1.4.0
    • Fix Version/s: None
    • Labels:
      None

      Description

      After having updated our ezstudio installation to Fast Track Release v1.4.0 we encountered errors after having added a new user via the admin interface.

      Steps to reproduce:

      • Add a new user via the admin interface (being it the first time with v1.4.0)
      • Next try to add again a new user

      It will fail and the REST interface returns the following json error object:

      ErrorMessage:Object
      _media-type:"application/vnd.ez.api.ErrorMessage+json"
      errorCode:500
      errorMessage:"Internal Server Error"
      errorDescription:"Database error"
      trace:"#0 /home/disk2/dev/projects/fvs/public_website/vendor/ezsystems/ezpublish-kernel/eZ/Publish/Core/Persistence/Legacy/User/Handler.php(84): eZ\Publish\Core\Persistence\Legacy\User\Gateway\ExceptionConversion->createUser(Object(eZ\Publish\SPI\Persistence\User))
      #1 /home/disk2/dev/projects/fvs/public_website/app/cache/dev/appDevDebugProjectContainer.php(145186): eZ\Publish\Core\Persistence\Legacy\User\Handler->create(Object(eZ\Publish\SPI\Persistence\User))
      #2 /home/disk2/dev/projects/fvs/public_website/vendor/ezsystems/ezpublish-kernel/eZ/Publish/Core/Persistence/Cache/UserHandler.php(32): eZPublishCorePersistenceLegacyUserHandler_0000000021f6acc9000000002dd3d4976700de27e68fc0e7d2874dc46b8076b2->create(Object(eZ\Publish\SPI\Persistence\User))
      #3 /home/disk2/dev/projects/fvs/public_website/vendor/ezsystems/ezpublish-kernel/eZ/Publish/Core/Repository/UserService.php(488): eZ\Publish\Core\Persistence\Cache\UserHandler->create(Object(eZ\Publish\SPI\Persistence\User))
      #4 /home/disk2/dev/projects/fvs/public_website/vendor/ezsystems/ezpublish-kernel/eZ/Publish/Core/SignalSlot/UserService.php(218): eZ\Publish\Core\Repository\UserService->createUser(Object(eZ\Publish\Core\Repository\Values\User\UserCreateStruct), Array)
      #5 /home/disk2/dev/projects/fvs/public_website/vendor/ezsystems/platform-ui-bundle/Controller/Rest/ContentController.php(39): eZ\Publish\Core\SignalSlot\UserService->createUser(Object(eZ\Publish\Core\Repository\Values\User\UserCreateStruct), Array)
      #6 [internal function]: EzSystems\PlatformUIBundle\Controller\Rest\ContentController->createContent(Object(Symfony\Component\HttpFoundation\Request))
      #7 /home/disk2/dev/projects/fvs/public_website/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php(144): call_user_func_array(Array, Array)
      #8 /home/disk2/dev/projects/fvs/public_website/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/HttpKernel.php(64): Symfony\Component\HttpKernel\HttpKernel->handleRaw(Object(Symfony\Component\HttpFoundation\Request), 1)
      #9 /home/disk2/dev/projects/fvs/public_website/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/DependencyInjection/ContainerAwareHttpKernel.php(69): Symfony\Component\HttpKernel\HttpKernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)
      #10 /home/disk2/dev/projects/fvs/public_website/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php(193): Symfony\Component\HttpKernel\DependencyInjection\ContainerAwareHttpKernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)
      #11 /home/disk2/dev/projects/fvs/public_website/web/app.php(66): Symfony\Component\HttpKernel\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request))
      #12

      {main}

      "
      file:"/home/disk2/dev/projects/fvs/public_website/vendor/ezsystems/ezpublish-kernel/eZ/Publish/Core/Persistence/Legacy/User/Gateway/ExceptionConversion.php"

      Debugging showed that since v1.4.0 the column ezuser.login_normalized is not filled any more and may cause the error. If we manually insert the value for ezuser.login_normalized in the database everything works fine again.

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            rafael.dominguez Rafael Dominguez Santos
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: