Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-26130

Search for content in many location hangs UI

    Details

      Description

      Search for content which is in two or more different location hangs the UI.

      Steps to reproduce:
      1. Create some content
      2. Add another location for this content
      3. Try to search for that content via 'Platform UI Search Prototype Bundle' (from left side menu choose 'Search' and type the name of content in search input)

      Notice the infinite loading spinner.

        Issue Links

          Activity

          Hide
          Damien Pobel (Inactive) added a comment - - edited

          Confirmed, I get the following error in the console:

          Uncaught TypeError: Cannot read property 'get' of undefined
          

          the issue seems to happen as long as a Content item with multiple Locations appears in the result.

          Show
          Damien Pobel (Inactive) added a comment - - edited Confirmed, I get the following error in the console: Uncaught TypeError: Cannot read property 'get' of undefined the issue seems to happen as long as a Content item with multiple Locations appears in the result.
          Hide
          Yannick Roger (Inactive) added a comment -

          Make sure to test (and close as duplicate if test is positive) EZP-26115

          Show
          Yannick Roger (Inactive) added a comment - Make sure to test (and close as duplicate if test is positive) EZP-26115
          Show
          Stéphane Diot added a comment - PR : https://github.com/ezsystems/PlatformUIBundle/pull/669
          Show
          Stéphane Diot added a comment - Merged at : https://github.com/ezsystems/PlatformUIBundle/commit/db41c76376b47b27e4417905a0daa86f2596837b into 1.4
          Show
          Yannick Roger (Inactive) added a comment - Fixed in 1.4, 1.5.1 and 1.6: https://github.com/ezsystems/PlatformUIBundle/commit/1119533806a8a3d54e5d61a3ac872788f0ac9c67
          Hide
          André Rømcke added a comment - - edited

          Hi Peter Halasz,

          this Platform UI issue was reported when upgrade to 1.4 was attempted, but as it was never reported to Support so QA has no channel to ask: Does this also affects you on 1.3? I assume not as this was triggered by FullTextSearchBundle and you have your own version of that now which as far as I know fixed this, right?

          Best,
          André

          cc Łukasz Serwatka

          Show
          André Rømcke added a comment - - edited Hi Peter Halasz , this Platform UI issue was reported when upgrade to 1.4 was attempted, but as it was never reported to Support so QA has no channel to ask: Does this also affects you on 1.3? I assume not as this was triggered by FullTextSearchBundle and you have your own version of that now which as far as I know fixed this, right? Best, André cc Łukasz Serwatka
          Hide
          Paulo Nunes (Inactive) added a comment -

          QA Approved
          Tested on 1.4, 1.5 and 1.6

          Show
          Paulo Nunes (Inactive) added a comment - QA Approved Tested on 1.4, 1.5 and 1.6

            People

            • Assignee:
              Unassigned
              Reporter:
              Dariusz Szut
            • Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: