Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-26060

Embedded contents in RichText are not displayed properly

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Duplicate
    • Affects Version/s: 1.4.0
    • Fix Version/s: None
    • Labels:
    • Environment:

      Custom install with upgraded ezplatform 1.4.0
      Same on a fresh ezdemo install and the builtin server (attached screenshot related to this install)
      Tried with PHP 5.5.37 and 5.6.23

      Description

      When rendering a RichText field containing an embedded object, the HTML output is always escaped. Without any success, I tried :

      • to disable twig.autoescape globally
      • to add {% autoescape false %}

        directive

      • to add `|raw` filter in the ezrichtext_field block (content_fields.html.twig)

      Note that all the other parts (paragraph, headings, etc...) within the same RichText field are rendered without any issue which is really weird...

      The issue applies to embedded object or embedded image (which is probably the same in the underlying API).

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              arnaud.lafon@gmail.com Arnaud Lafon
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: