Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-26022

Execute composer update prior to Setup Wizard results in errors due to ezsystems/ezpublish-legacy-installer plugin




      If you install eZ Publish using the E.E. tarbal and executing composer update prior to the Setup Wizard, you will get errors and/or warnings due to "ezsystems/ezpublish-legacy-installer" plugin.

      Please notice these steps were performed according to the 5.4.x Update Instructions and Using Composer documentation pages. If it's not possible to use the latest version of composer, there should be a warning in the documentation or a way to change the "ezsystems/ezpublish-legacy-installer" plugin in order to work with the latest version.

      Steps to reproduce

      1. Download composer according to the Using Composer documentation page.
        php -r "readfile('https://getcomposer.org/installer');" | php
      2. Extract the ezpublish 5.4 tarball from eZ Publish Enterprise downloads.
      3. Follow the steps described in the 5.4.x Update Instructions documentation page.
        php -d memory_limit=-1 composer.phar remove behat/mink-selenium-driver --no-update --dev
        php -d memory_limit=-1 composer.phar require --no-update symfony/symfony:~2.7.0 sensio/distribution-bundle:~3.0
        php -d memory_limit=-1 composer.phar update --no-dev --prefer-dist
      4. At this point, you will get the following error

        The "ezsystems/ezpublish-legacy-installer" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.

      5. As a workaround described in EZP-25774, open the Composer Manual Download page and download the 1.0.0 version.
      6. Execute the update step again
        php -d memory_limit=-1 composer.phar update --no-dev --prefer-dist
      7. At this point, you will get the following warning

        The "ezsystems/ezpublish-legacy-installer" plugin requires composer-plugin-api 1.0.0, this WILL break in the future and it should be fixed ASAP (require ^1.0 for example).


          Issue Links



              • Assignee:
                eduardo.fernandes-obsolete@ez.no Eduardo Fernandes (Inactive)
              • Votes:
                0 Vote for this issue
                2 Start watching this issue


                • Created: