Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-26009

Unable to install eZ Platform 1.4.0 using PHP 7.0.5

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Obsolete
    • Affects Version/s: 1.4.0
    • Fix Version/s: None
    • Component/s: Composer
    • Labels:
      None

      Description

      I'm unable to install eZ Platform 1.4.0 using PHP 7.0.5, it will throw the following error

      Installing ezsystems/ezplatform (v1.4.0)
        - Installing ezsystems/ezplatform (v1.4.0)
          Downloading: 100%         
      
      Created project in site
      Loading composer repositories with package information
      Installing dependencies from lock file
      Your requirements could not be resolved to an installable set of packages.
      
        Problem 1
          - Installation request for zendframework/zend-code 2.6.3 -> satisfiable by zendframework/zend-code[2.6.3].
          - zendframework/zend-code 2.6.3 requires php ^5.5 || 7.0.0 - 7.0.4 || ^7.0.6 -> your PHP version (7.0.5) does not satisfy that requirement.
        Problem 2
          - zendframework/zend-code 2.6.3 requires php ^5.5 || 7.0.0 - 7.0.4 || ^7.0.6 -> your PHP version (7.0.5) does not satisfy that requirement.
          - ocramius/proxy-manager 1.0.2 requires zendframework/zend-code >2.2.5,<3.0 -> satisfiable by zendframework/zend-code[2.6.3].
          - Installation request for ocramius/proxy-manager 1.0.2 -> satisfiable by ocramius/proxy-manager[1.0.2].
      

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            pedro.resende-obsolete@ez.no Pedro Resende (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: