Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-25966

Embeds in RichText are rendered as literal HTML in some setups

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.4.0-rc1, 1.6.1, 1.12.1
    • Fix Version/s: Customer request
    • Component/s: Field types
    • Labels:
      None
    • Environment:

      Mac OS
      PHP 7
      libxml Version => 2.9.3
      libxslt Version => 1.1.28

      Description

      With PHP 7.0.6 installed via homebrew on mac os, with the libxslt/libxml versions described in environment, embeds are htmlentities encoded, and rendered as literal HTML.

      It has been reproduced on two PHP 7 installations on mac os, with the same result.

        Issue Links

          Activity

          Io Sol Inf added a comment -

          André Rømcke, I don't thibnk that my hack can be applied in production. If I recall correctly, it solved the issue in DEV but it seems to much "hackish" to be applied in PROD.
          I'll check if the issue still exists with the latest eZPlatform / OSX updates.

          Bertrand Dunogier added a comment -

          It still exists on eZ Platform 1.9.0-rc1, at least. And the fix you have suggested still works.
          Note that your fix doesn't apply to the prod environment, as the DebugTemplate class is only used in prod. The annoying part is that it only affects some setups, not all.

          Jani Tarvainen added a comment -

          I continued to experience this issue with PHP 7.1.4 package from Brew on Mac OS X (10.11.16). I tried a few different things to try to update the package to use a newer libxml2/libxslt versions, but didn't get it to work it. For now me the easiest solution was to replace the Brew PHP package with the LIIP one from https://php-osx.liip.ch.

          Version details, etc. here: http://share.ez.no/forums/ez-platform/ez-platform-image-embed-output-escaped-on-macos-os-x/(offset)/last

          André Rømcke added a comment - - edited

          Closing as Won't Fix as this can't be solved in a clean way given it's a issue coming from what seems to be old libxml used in compiling Homebrew php package for MacOs.

          Our recommendation is to use something else the brew for php, especially now that Homebrew has deprecated the php recipe earlier this year
          For instance LIIP packages does not have this issue.

          André Rømcke added a comment -

          Small correction on comment above, it seems this is now fixed in brew. The php package has been moved into core and the issue is no longer present in the new package.

          Instructions from someone using brew:
          > deleting previous version(s) and install current one by
          brew install php@7.1
          > will fix the issue, I've just test it on osx 10.12.6, php 7.1.17, libxml2 2.9.4, libxslt 1.1.29 (libxslt compiled against libxml Version 2.9.4)
          and I can see embeded images in richtext on platform-ee-demo


            People

            • Assignee:
              Unassigned
              Reporter:
              Bertrand Dunogier
            • Votes:
              1 Vote for this issue
              Watchers:
              11 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: