Details

    • Type: Bug Bug
    • Status: Confirmed
    • Priority: High High
    • Resolution: Unresolved
    • Affects Version/s: 1.3.0, 1.4.0-beta1, 1.5.0, 1.7.0, 1.7.1, 1.8.0, 1.7.2, 1.9.0-rc
    • Fix Version/s: QA tracked issues
    • Component/s: Platform stack
    • Labels:
    • Environment:

      Operating System: Debian 8
      PHP Version: 5.6.14-0+deb8u1
      Database and version: Mysql 5.5.46-0+deb8u1
      Browser (and version): Firefox

      Description

      Steps to reproduce
      • Create a content type that has an ezrrating fieldtype
      • Create a content of previous content type
      • Access it through frontend

      A fatal error is displayed

      The server returned a "500 Internal Server Error".
      

      In logs I have

      [2016-05-20 12:25:40] request.CRITICAL: Uncaught PHP Exception Twig_Error_Runtime: "An exception has been thrown during the rendering of a template ("Cannot find 'ezsrrating_field' template block.") in "EzPublishCoreBundle:default:content/full.html.twig" at line 6." at /var/www/ezp60/ezplatform/vendor/twig/twig/lib/Twig/Template.php line 182 {"exception":"[object] (Twig_Error_Runtime(code: 0): An exception has been thrown during the rendering of a template (\"Cannot find 'ezsrrating_field' template block.\") in \"EzPublishCoreBundle:default:content/full.html.twig\" at line 6. at /var/www/ezp60/ezplatform/vendor/twig/twig/lib/Twig/Template.php:182, eZ\\Publish\\Core\\MVC\\Symfony\\Templating\\Exception\\MissingFieldBlockException(code: 0): Cannot find 'ezsrrating_field' template block. at /var/www/ezp60/ezplatform/vendor/ezsystems/ezpublish-kernel/eZ/Publish/Core/MVC/Symfony/Templating/Twig/FieldBlockRenderer.php:320)"} []
      

        Issue Links

          Activity

          Paulo Nunes (Inactive) created issue -
          Rui Silva (Inactive) made changes -
          Field Original Value New Value
          Status Open [ 1 ] Confirmed [ 10037 ]
          Hide
          Bertrand Dunogier added a comment -

          Could you please test this against the previous stable version as well ?

          Show
          Bertrand Dunogier added a comment - Could you please test this against the previous stable version as well ?
          Damien Pobel (Inactive) made changes -
          Component/s Platform stack [ 10303 ]
          Component/s Platform UI (Admin UI & Content UI) [ 10301 ]
          Hide
          Damien Pobel (Inactive) added a comment -

          (Removed PlatformUI from the components, since this has nothing to do with PlatformUI. Also I set the component to "Platform stack" but I'm unsure if it's the right one)

          Show
          Damien Pobel (Inactive) added a comment - (Removed PlatformUI from the components, since this has nothing to do with PlatformUI. Also I set the component to "Platform stack" but I'm unsure if it's the right one)
          Hide
          Bertrand Dunogier added a comment -

          It turns out that the templates for the rating fieldtype were never implemented. As far as I can tell the feature is half-done, and not that useful at the moment.

          Show
          Bertrand Dunogier added a comment - It turns out that the templates for the rating fieldtype were never implemented. As far as I can tell the feature is half-done, and not that useful at the moment.
          Paulo Nunes (Inactive) made changes -
          Affects Version/s 1.4.0-beta1 [ 14528 ]
          Paulo Nunes (Inactive) made changes -
          Affects Version/s 1.5.0 [ 14582 ]
          André Rømcke made changes -
          Link This issue relates to EZP-24317 [ EZP-24317 ]
          Bertrand Dunogier made changes -
          Summary Fatal error when viewing a content in frontend with a rating fieldtype Rating FieldType isn't viable
          Hide
          Bertrand Dunogier added a comment -

          Either the FieldType must be disabled (complex due to BC, but who would use it in this state), or it must be fixed.

          It is not implemented at all, and doesn't store anything interesting that I can see. It's more of a Feature request than a bug tbh. Is the FieldType listed in the documentation ?

          Show
          Bertrand Dunogier added a comment - Either the FieldType must be disabled (complex due to BC, but who would use it in this state), or it must be fixed. It is not implemented at all, and doesn't store anything interesting that I can see. It's more of a Feature request than a bug tbh. Is the FieldType listed in the documentation ?
          Bertrand Dunogier made changes -
          Link This issue relates to EZP-22584 [ EZP-22584 ]
          Paulo Nunes (Inactive) made changes -
          Affects Version/s 1.7.1 [ 14681 ]
          Affects Version/s 1.7.0 [ 14616 ]
          Affects Version/s 1.8.0 [ 14682 ]
          Paulo Nunes (Inactive) made changes -
          Affects Version/s 1.7.2 [ 14690 ]
          Hide
          Sylvain Guittard added a comment -

          I agree with Bertrand: it's more a feature than a bug. And this feature is not planned for now.

          Show
          Sylvain Guittard added a comment - I agree with Bertrand: it's more a feature than a bug. And this feature is not planned for now.
          Paulo Nunes (Inactive) made changes -
          Affects Version/s 1.9.0-rc [ 14705 ]
          Alex Schuster made changes -
          Workflow EZ* Development Workflow [ 98899 ] EZEE Development Workflow [ 108698 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Confirmed Confirmed
          15m 49s 1 rui.silva@ez.no 20/May/16 4:00 PM

            People

            • Assignee:
              Unassigned
              Reporter:
              Paulo Nunes (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated: