Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-25774

Cannot update 5.3.x and 5.4.x using latest composer version

    Details

      Description

      Currently cannot install an up-to-date 5.3, neither via the tarball with subsequent update process from the documentation, nor using git.

      When running the command from the documentation to update:

      php -d memory_limit=-1 composer.phar update --no-dev --prefer-dist --with-dependencies ezsystems/ezpublish-kernel ezsystems/demobundle ezsystems/ezpublish-legacy symfony/symfony
      

      or when running the command:

      php  -d memory_limit=-1 composer.phar install --prefer-dist --no-dev
      

      to install my ezpublish fetched from git, I get the following error:

      Updating dependencies
      Your requirements could not be resolved to an installable set of packages.
       
        Problem 1
          - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
          - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
          - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
          - Installation request for ezsystems/ezpublish-legacy-installer (locked at v2.0.0) -> satisfiable by ezsystems/ezpublish-legacy-installer[v2.0.0].
       
      Potential causes:
       - A typo in the package name
       - The package is not available in a stable-enough version according to your minimum-stability setting
         see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.
       
      Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
      

      It appears this happens since update to last version of composer 1.1.0, from May the 10th, 2016 (two days ago)
      However, if I manually fetch a previous version such as 1.0.3, for instance, it does work.

        Issue Links

          Activity

          Hide
          Paulo Nunes (Inactive) added a comment - - edited

          When running the some of the composer commands referred by [~rui.silva@ez.no] , some messages of the following type appears

          The "ezsystems/ezpublish-legacy-installer" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
          The "bitexpert/composer-authstore-plugin" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
          

          But even using the --no-plugins parameter does not solve the problem and I ended up having the same errors described by [~rui.silva@ez.no].
          Also for me, as referred, using composer 1.0.3 solves the issue.

          +1 for confirmation

          Show
          Paulo Nunes (Inactive) added a comment - - edited When running the some of the composer commands referred by [~rui.silva@ez.no] , some messages of the following type appears The "ezsystems/ezpublish-legacy-installer" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option. The "bitexpert/composer-authstore-plugin" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option. But even using the --no-plugins parameter does not solve the problem and I ended up having the same errors described by [~rui.silva@ez.no] . Also for me, as referred, using composer 1.0.3 solves the issue. +1 for confirmation
          Hide
          Paulo Nunes (Inactive) added a comment -

          related EZP-25582 - "Updating 5.3.x and 5.4.x to latest versions raise warning that "will break in the future""
          Seems that the future has arrived.

          Show
          Paulo Nunes (Inactive) added a comment - related EZP-25582 - "Updating 5.3.x and 5.4.x to latest versions raise warning that "will break in the future"" Seems that the future has arrived.
          Hide
          Joao Inacio (Inactive) added a comment - - edited

          This has been resolved in legacy-installer v2.0.1 with @127643119288c6a4

          Updating to the latest version should work:

          $ composer require ezsystems/ezpublish-legacy-installer:~2.0.3
          

          It's possible that the update documentation needs to reflect this

          Show
          Joao Inacio (Inactive) added a comment - - edited This has been resolved in legacy-installer v2.0.1 with @127643119288c6a4 Updating to the latest version should work: $ composer require ezsystems/ezpublish-legacy-installer:~2.0.3 It's possible that the update documentation needs to reflect this
          Hide
          Paulo Nunes (Inactive) added a comment - - edited

          Updating to the latest version should work:
          $ composer require ezsystems/ezpublish-legacy-installer:~2.0.3

          Unfortunately it didn't. worked
          I tried to include the referred require in composer.json and to add ezsystems/ezpublish-legacy-installer in the update command, but an error still occur.

           Problem 1
              - bitexpert/composer-authstore-plugin 0.2.1 requires composer-plugin-api 1.0.0 -> no matching package found.
              - bitexpert/composer-authstore-plugin 0.2.1 requires composer-plugin-api 1.0.0 -> no matching package found.
              - bitexpert/composer-authstore-plugin 0.2.1 requires composer-plugin-api 1.0.0 -> no matching package found.
              - Installation request for bitexpert/composer-authstore-plugin (locked at 0.2.1, required as 0.2.*) -> satisfiable by bitexpert/composer-authstore-plugin[0.2.1].
          

          Show
          Paulo Nunes (Inactive) added a comment - - edited Updating to the latest version should work: $ composer require ezsystems/ezpublish-legacy-installer:~2.0.3 Unfortunately it didn't. worked I tried to include the referred require in composer.json and to add ezsystems/ezpublish-legacy-installer in the update command, but an error still occur. Problem 1 - bitexpert/composer-authstore-plugin 0.2.1 requires composer-plugin-api 1.0.0 -> no matching package found. - bitexpert/composer-authstore-plugin 0.2.1 requires composer-plugin-api 1.0.0 -> no matching package found. - bitexpert/composer-authstore-plugin 0.2.1 requires composer-plugin-api 1.0.0 -> no matching package found. - Installation request for bitexpert/composer-authstore-plugin (locked at 0.2.1, required as 0.2.*) -> satisfiable by bitexpert/composer-authstore-plugin[0.2.1].
          Hide
          André Rømcke added a comment - - edited

          Auth is built in now in composer, so you can (and we should have documented in update instructions to remove it).

          composer remove bitexpert/composer-authstore-plugin
          

          Show
          André Rømcke added a comment - - edited Auth is built in now in composer, so you can (and we should have documented in update instructions to remove it). composer remove bitexpert/composer-authstore-plugin
          Show
          André Rømcke added a comment - Doc updated: https://doc.ez.no/display/EZP/5.3.x+Update+Instructions
          Hide
          Paulo Nunes (Inactive) added a comment -

          Still no go, the authstore-plugin 0.2.1 error still happens
          After installing a 5.3.0 and trying to update it to latest version, I have (full upgrade steps):

          $ php -d memory_limit=-1 composer.phar remove --no-update zetacomponents/archive zetacomponents/authentication zetacomponents/authentication-database-tiein zetacomponents/base zetacomponents/cache zetacomponents/configuration zetacomponents/console-tools zetacomponents/database zetacomponents/debug zetacomponents/event-log zetacomponents/feed zetacomponents/image-conversion zetacomponents/mail zetacomponents/mvc-tools zetacomponents/mvc-authentication-tiein zetacomponents/persistent-object zetacomponents/php-generator zetacomponents/signal-slot zetacomponents/system-information
           
          The "ezsystems/ezpublish-legacy-installer" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
          The "bitexpert/composer-authstore-plugin" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
          You are running composer with xdebug enabled. This has a major impact on runtime performance. See https://getcomposer.org/xdebug
           
          $ php -d memory_limit=-1 composer.phar remove --no-update --dev behat/mink-selenium-driver
           
          The "ezsystems/ezpublish-legacy-installer" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
          The "bitexpert/composer-authstore-plugin" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
          You are running composer with xdebug enabled. This has a major impact on runtime performance. See https://getcomposer.org/xdebug
           
          $ php -d memory_limit=-1 composer.phar remove --no-update bitexpert/composer-authstore-plugin
           
          The "ezsystems/ezpublish-legacy-installer" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
          The "bitexpert/composer-authstore-plugin" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
          You are running composer with xdebug enabled. This has a major impact on runtime performance. See https://getcomposer.org/xdebug
           
          $ php -d memory_limit=-1 composer.phar update --no-dev --prefer-dist --with-dependencies ezsystems/ezpublish-kernel ezsystems/demobundle ezsystems/ezpublish-legacy symfony/symfony ezsystems/ezpublish-legacy-installer
           
          The "ezsystems/ezpublish-legacy-installer" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
          The "bitexpert/composer-authstore-plugin" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
          You are running composer with xdebug enabled. This has a major impact on runtime performance. See https://getcomposer.org/xdebug
          Dependency "doctrine/doctrine-bundle" is also a root requirement, but is not explicitly whitelisted. Ignoring.
          Dependency "nelmio/cors-bundle" is also a root requirement, but is not explicitly whitelisted. Ignoring.
          Dependency "sensio/distribution-bundle" is also a root requirement, but is not explicitly whitelisted. Ignoring.
          Dependency "tedivm/stash-bundle" is also a root requirement, but is not explicitly whitelisted. Ignoring.
          Dependency "ezsystems/comments-bundle" is also a root requirement, but is not explicitly whitelisted. Ignoring.
          Loading composer repositories with package information
          Updating dependencies
          Your requirements could not be resolved to an installable set of packages.
           
            Problem 1
              - bitexpert/composer-authstore-plugin 0.2.1 requires composer-plugin-api 1.0.0 -> no matching package found.
              - bitexpert/composer-authstore-plugin 0.2.1 requires composer-plugin-api 1.0.0 -> no matching package found.
              - bitexpert/composer-authstore-plugin 0.2.1 requires composer-plugin-api 1.0.0 -> no matching package found.
              - Installation request for bitexpert/composer-authstore-plugin (locked at 0.2.1) -> satisfiable by bitexpert/composer-authstore-plugin[0.2.1].
           
          Potential causes:
           - A typo in the package name
           - The package is not available in a stable-enough version according to your minimum-stability setting
             see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.
           
          Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
          

          Might be due still having bitexpert/composer-authstore-plugin referred in composer.lock?

          Show
          Paulo Nunes (Inactive) added a comment - Still no go, the authstore-plugin 0.2.1 error still happens After installing a 5.3.0 and trying to update it to latest version, I have (full upgrade steps): $ php -d memory_limit=-1 composer.phar remove --no-update zetacomponents/archive zetacomponents/authentication zetacomponents/authentication-database-tiein zetacomponents/base zetacomponents/cache zetacomponents/configuration zetacomponents/console-tools zetacomponents/database zetacomponents/debug zetacomponents/event-log zetacomponents/feed zetacomponents/image-conversion zetacomponents/mail zetacomponents/mvc-tools zetacomponents/mvc-authentication-tiein zetacomponents/persistent-object zetacomponents/php-generator zetacomponents/signal-slot zetacomponents/system-information   The "ezsystems/ezpublish-legacy-installer" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option. The "bitexpert/composer-authstore-plugin" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option. You are running composer with xdebug enabled. This has a major impact on runtime performance. See https://getcomposer.org/xdebug   $ php -d memory_limit=-1 composer.phar remove --no-update --dev behat/mink-selenium-driver   The "ezsystems/ezpublish-legacy-installer" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option. The "bitexpert/composer-authstore-plugin" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option. You are running composer with xdebug enabled. This has a major impact on runtime performance. See https://getcomposer.org/xdebug   $ php -d memory_limit=-1 composer.phar remove --no-update bitexpert/composer-authstore-plugin   The "ezsystems/ezpublish-legacy-installer" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option. The "bitexpert/composer-authstore-plugin" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option. You are running composer with xdebug enabled. This has a major impact on runtime performance. See https://getcomposer.org/xdebug   $ php -d memory_limit=-1 composer.phar update --no-dev --prefer-dist --with-dependencies ezsystems/ezpublish-kernel ezsystems/demobundle ezsystems/ezpublish-legacy symfony/symfony ezsystems/ezpublish-legacy-installer   The "ezsystems/ezpublish-legacy-installer" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option. The "bitexpert/composer-authstore-plugin" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option. You are running composer with xdebug enabled. This has a major impact on runtime performance. See https://getcomposer.org/xdebug Dependency "doctrine/doctrine-bundle" is also a root requirement, but is not explicitly whitelisted. Ignoring. Dependency "nelmio/cors-bundle" is also a root requirement, but is not explicitly whitelisted. Ignoring. Dependency "sensio/distribution-bundle" is also a root requirement, but is not explicitly whitelisted. Ignoring. Dependency "tedivm/stash-bundle" is also a root requirement, but is not explicitly whitelisted. Ignoring. Dependency "ezsystems/comments-bundle" is also a root requirement, but is not explicitly whitelisted. Ignoring. Loading composer repositories with package information Updating dependencies Your requirements could not be resolved to an installable set of packages.   Problem 1 - bitexpert/composer-authstore-plugin 0.2.1 requires composer-plugin-api 1.0.0 -> no matching package found. - bitexpert/composer-authstore-plugin 0.2.1 requires composer-plugin-api 1.0.0 -> no matching package found. - bitexpert/composer-authstore-plugin 0.2.1 requires composer-plugin-api 1.0.0 -> no matching package found. - Installation request for bitexpert/composer-authstore-plugin (locked at 0.2.1) -> satisfiable by bitexpert/composer-authstore-plugin[0.2.1].   Potential causes: - A typo in the package name - The package is not available in a stable-enough version according to your minimum-stability setting see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.   Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems. Might be due still having bitexpert/composer-authstore-plugin referred in composer.lock?
          Hide
          Paulo Nunes (Inactive) added a comment -

          This problem also affects 5.4.x

          The "ezsystems/ezpublish-legacy-installer" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
          Dependency "hautelook/templated-uri-bundle" is also a root requirement, but is not explicitly whitelisted. Ignoring.
          Dependency "nelmio/cors-bundle" is also a root requirement, but is not explicitly whitelisted. Ignoring.
          Dependency "sensio/distribution-bundle" is also a root requirement, but is not explicitly whitelisted. Ignoring.
          Dependency "sensio/framework-extra-bundle" is also a root requirement, but is not explicitly whitelisted. Ignoring.
          Dependency "tedivm/stash-bundle" is also a root requirement, but is not explicitly whitelisted. Ignoring.
          Dependency "ezsystems/comments-bundle" is also a root requirement, but is not explicitly whitelisted. Ignoring.
          Package "ezsystems/ezplatform-solr-search-engine" listed for update is not installed. Ignoring.
          Loading composer repositories with package information
          Updating dependencies
          Your requirements could not be resolved to an installable set of packages.
           
            Problem 1
              - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
              - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
              - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
              - Installation request for ezsystems/ezpublish-legacy-installer (locked at v2.0.0) -> satisfiable by ezsystems/ezpublish-legacy-installer[v2.0.0].
           
          Potential causes:
           - A typo in the package name
           - The package is not available in a stable-enough version according to your minimum-stability setting
             see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.
           
          Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
          
          

          Show
          Paulo Nunes (Inactive) added a comment - This problem also affects 5.4.x The "ezsystems/ezpublish-legacy-installer" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option. Dependency "hautelook/templated-uri-bundle" is also a root requirement, but is not explicitly whitelisted. Ignoring. Dependency "nelmio/cors-bundle" is also a root requirement, but is not explicitly whitelisted. Ignoring. Dependency "sensio/distribution-bundle" is also a root requirement, but is not explicitly whitelisted. Ignoring. Dependency "sensio/framework-extra-bundle" is also a root requirement, but is not explicitly whitelisted. Ignoring. Dependency "tedivm/stash-bundle" is also a root requirement, but is not explicitly whitelisted. Ignoring. Dependency "ezsystems/comments-bundle" is also a root requirement, but is not explicitly whitelisted. Ignoring. Package "ezsystems/ezplatform-solr-search-engine" listed for update is not installed. Ignoring. Loading composer repositories with package information Updating dependencies Your requirements could not be resolved to an installable set of packages.   Problem 1 - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found. - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found. - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found. - Installation request for ezsystems/ezpublish-legacy-installer (locked at v2.0.0) -> satisfiable by ezsystems/ezpublish-legacy-installer[v2.0.0].   Potential causes: - A typo in the package name - The package is not available in a stable-enough version according to your minimum-stability setting see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.   Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
          Hide
          André Rømcke added a comment -

          Was fixed a year ago, you'll need to make sure {{ezpublish-legacy-installer}}gets updated:
          https://github.com/ezsystems/ezpublish-legacy-installer/commit/127643119288c6a47b8ef8bf7018c8a01cfdc788

          Show
          André Rømcke added a comment - Was fixed a year ago, you'll need to make sure {{ezpublish-legacy-installer}}gets updated: https://github.com/ezsystems/ezpublish-legacy-installer/commit/127643119288c6a47b8ef8bf7018c8a01cfdc788
          Hide
          Paulo Nunes (Inactive) added a comment -

          André Rømcke: replacing the update i.e,
          replace php -d memory_limit=-1 composer.phar update --no-dev --prefer-dist --with-dependencies ezsystems/ezpublish-kernel ezsystems/demobundle ezsystems/ezpublish-legacy symfony/symfony ezsystems/ezpublish-legacy-installer
          by
          php -d memory_limit=-1 composer.phar update --prefer-dist

          Then the error no longer happens. Only a deprecation notice remains

          Deprecation Notice: The callback Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installRequirementsFile declared at /var/www/html/ezp53/ezpublish5/vendor/sensio/distribution-bundle/Sensio/Bundle/DistributionBundle/Composer/ScriptHandler.php accepts a Composer\Script\CommandEvent but post-update-cmd events use a Composer\Script\Event instance. Please adjust your type hint accordingly, see https://getcomposer.org/doc/articles/scripts.md#event-classes in phar:///var/www/html/ezp53/ezpublish5/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:289
          

          Just for future memory (mine), the commands executed and output were

           php -d memory_limit=-1 composer.phar remove --no-update zetacomponents/archive zetacomponents/authentication zetacomponents/authentication-database-tiein zetacomponents/base zetacomponents/cache zetacomponents/configuration zetacomponents/console-tools zetacomponents/database zetacomponents/debug zetacomponents/event-log zetacomponents/feed zetacomponents/image-conversion zetacomponents/mail zetacomponents/mvc-tools zetacomponents/mvc-authentication-tiein zetacomponents/persistent-object zetacomponents/php-generator zetacomponents/signal-slot zetacomponents/system-information
          The "ezsystems/ezpublish-legacy-installer" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
          The "bitexpert/composer-authstore-plugin" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
          You are running composer with xdebug enabled. This has a major impact on runtime performance. See https://getcomposer.org/xdebug
          (COS-6.5)vagrant:{/var/www/html/ezp53/ezpublish5}-> php -d memory_limit=-1 composer.phar remove --no-update --dev behat/mink-selenium-driver
          The "ezsystems/ezpublish-legacy-installer" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
          The "bitexpert/composer-authstore-plugin" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
          You are running composer with xdebug enabled. This has a major impact on runtime performance. See https://getcomposer.org/xdebug
          (COS-6.5)vagrant:{/var/www/html/ezp53/ezpublish5}-> 
          (COS-6.5)vagrant:{/var/www/html/ezp53/ezpublish5}-> php -d memory_limit=-1 composer.phar remove --no-update bitexpert/composer-authstore-plugin
          The "ezsystems/ezpublish-legacy-installer" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
          The "bitexpert/composer-authstore-plugin" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
          You are running composer with xdebug enabled. This has a major impact on runtime performance. See https://getcomposer.org/xdebug
          (COS-6.5)vagrant:{/var/www/html/ezp53/ezpublish5}-> 
          (COS-6.5)vagrant:{/var/www/html/ezp53/ezpublish5}-> 
          (COS-6.5)vagrant:{/var/www/html/ezp53/ezpublish5}-> php -d memory_limit=-1 composer.phar update --prefer-dist
          The "ezsystems/ezpublish-legacy-installer" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
          The "bitexpert/composer-authstore-plugin" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
          You are running composer with xdebug enabled. This has a major impact on runtime performance. See https://getcomposer.org/xdebug
          Loading composer repositories with package information
          Updating dependencies (including require-dev)
            - Removing symfony/icu (v1.1.1)
            - Removing bitexpert/composer-authstore-plugin (0.2.1)
            - Removing ezsystems/ezpublish-legacy-installer (v2.0.0)
            - Installing ezsystems/ezpublish-legacy-installer (v2.0.3)
              Loading from cache
           
            - Removing twig/twig (v1.15.1)
            - Installing twig/twig (v1.24.1)
              Loading from cache
           
            - Removing doctrine/lexer (v1.0)
            - Installing doctrine/lexer (v1.0.1)
              Loading from cache
           
            - Removing doctrine/inflector (v1.0)
            - Installing doctrine/inflector (v1.1.0)
              Loading from cache
           
            - Removing doctrine/collections (v1.2)
            - Installing doctrine/collections (v1.3.0)
              Loading from cache
           
            - Removing doctrine/cache (v1.3.0)
            - Installing doctrine/cache (v1.5.4)
              Loading from cache
           
            - Removing doctrine/annotations (v1.1.2)
            - Installing doctrine/annotations (v1.2.7)
              Loading from cache
           
            - Removing doctrine/common (v2.4.2)
            - Installing doctrine/common (v2.5.3)
              Loading from cache
           
            - Installing symfony/polyfill-mbstring (v1.2.0)
              Loading from cache
           
            - Installing symfony/polyfill-apcu (v1.2.0)
              Loading from cache
           
            - Installing paragonie/random_compat (v1.4.1)
              Loading from cache
           
            - Removing symfony/symfony (v2.3.13)
            - Installing symfony/symfony (v2.3.42)
              Loading from cache
           
            - Removing kriswallsmith/assetic (v1.1.2)
            - Installing kriswallsmith/assetic (v1.1.3)
              Loading from cache
           
            - Removing symfony/assetic-bundle (v2.3.0)
            - Installing symfony/assetic-bundle (v2.3.1)
              Loading from cache
           
            - Removing swiftmailer/swiftmailer (v5.2.0)
            - Installing swiftmailer/swiftmailer (v5.4.2)
              Loading from cache
           
            - Removing symfony/swiftmailer-bundle (v2.3.7)
            - Installing symfony/swiftmailer-bundle (v2.3.11)
              Loading from cache
           
            - Removing sensio/distribution-bundle (v2.3.4)
            - Installing sensio/distribution-bundle (v2.3.22)
              Loading from cache
           
            - Removing sensio/generator-bundle (v2.3.4)
            - Installing sensio/generator-bundle (v2.3.5)
              Loading from cache
           
            - Removing incenteev/composer-parameter-handler (v2.1.0)
            - Installing incenteev/composer-parameter-handler (v2.1.2)
              Loading from cache
           
            - Installing netgen/ngsymfonytools (1.1)
              Loading from cache
           
            - Removing ezsystems/ngsymfonytools-bundle (v1.0.4)
            - Installing ezsystems/ngsymfonytools-bundle (v1.0.5)
              Loading from cache
           
            - Removing zetacomponents/base (dev-master 642f63a)
            - Installing zetacomponents/base (1.9)
              Loading from cache
           
            - Removing zetacomponents/mail (1.8beta1)
            - Installing zetacomponents/mail (1.8.1)
              Loading from cache
           
            - Removing pagerfanta/pagerfanta (v1.0.1)
            - Installing pagerfanta/pagerfanta (v1.0.3)
              Loading from cache
           
            - Removing zendframework/zend-stdlib (2.2.6)
            - Installing zendframework/zend-stdlib (2.2.10)
              Loading from cache
           
            - Removing zendframework/zend-eventmanager (2.2.6)
            - Installing zendframework/zend-eventmanager (2.2.10)
              Loading from cache
           
            - Removing zendframework/zend-code (2.2.6)
            - Installing zendframework/zend-code (2.2.10)
              Loading from cache
           
            - Removing ocramius/proxy-manager (0.5.1)
            - Installing ocramius/proxy-manager (1.0.2)
              Loading from cache
           
            - Removing nelmio/cors-bundle (1.3.0)
            - Installing nelmio/cors-bundle (1.3.3)
              Loading from cache
           
            - Removing kriswallsmith/buzz (v0.10)
            - Installing kriswallsmith/buzz (v0.15)
              Loading from cache
           
            - Removing doctrine/dbal (v2.4.2)
            - Installing doctrine/dbal (v2.4.5)
              Loading from cache
           
            - Removing ezsystems/ezpublish-kernel (v5.3.0)
            - Installing ezsystems/ezpublish-kernel (v5.3.8)
              Loading from cache
           
            - Removing zetacomponents/php-generator (dev-master b51935e)
            - Installing zetacomponents/php-generator (1.1)
              Loading from cache
           
            - Removing ezsystems/comments-bundle (v5.3.0)
            - Installing ezsystems/comments-bundle (v5.3.2)
              Loading from cache
           
            - Removing ezsystems/demobundle (v5.3.0)
            - Installing ezsystems/demobundle (v5.3.5)
              Loading from cache
           
            - Removing egulias/listeners-debug-command-bundle (1.9.0)
            - Installing egulias/listeners-debug-command-bundle (1.9.1)
              Loading from cache
           
            - Removing white-october/pagerfanta-bundle (v1.0.2)
            - Installing white-october/pagerfanta-bundle (v1.0.6)
              Loading from cache
           
            - Removing monolog/monolog (1.9.1)
            - Installing monolog/monolog (1.19.0)
              Loading from cache
           
            - Removing zetacomponents/image-analysis (1.1.3)
            - Installing zetacomponents/image-analysis (1.2)
              Loading from cache
           
            - Installing behat/sahi-client (dev-master edd87e8)
              Loading from cache
           
            - Installing ezsystems/behatbundle (v5.3.0)
              Loading from cache
           
            - Removing zetacomponents/webdav (1.1.3)
            - Installing zetacomponents/webdav (1.2)
              Loading from cache
           
            - Removing zetacomponents/system-information (dev-master 6743362)
            - Installing zetacomponents/system-information (1.1)
              Loading from cache
           
            - Removing zetacomponents/signal-slot (dev-master 74deb41)
            - Installing zetacomponents/signal-slot (1.2)
              Loading from cache
           
            - Removing zetacomponents/persistent-object (dev-master a4c8b95)
            - Installing zetacomponents/persistent-object (1.8)
              Loading from cache
           
            - Removing zetacomponents/mvc-tools (dev-master 6f2c1eb)
            - Installing zetacomponents/mvc-tools (1.2.1)
              Loading from cache
           
            - Removing zetacomponents/authentication (dev-master c422670)
            - Installing zetacomponents/authentication (1.4)
              Loading from cache
           
            - Removing zetacomponents/mvc-authentication-tiein (dev-master 9bae3a7)
            - Installing zetacomponents/mvc-authentication-tiein (1.1)
              Loading from cache
           
            - Removing zetacomponents/image-conversion (dev-master 36f34c8)
            - Installing zetacomponents/image-conversion (1.4)
              Loading from cache
           
            - Removing zetacomponents/feed (dev-master e0190e9)
            - Installing zetacomponents/feed (1.4)
              Loading from cache
           
            - Removing zetacomponents/event-log (dev-master eee54a1)
            - Installing zetacomponents/event-log (1.5)
              Loading from cache
           
            - Removing zetacomponents/debug (dev-master 0d8cc8f)
            - Installing zetacomponents/debug (1.3)
              Loading from cache
           
            - Removing zetacomponents/database (dev-master 0e8ddef)
            - Installing zetacomponents/database (1.5)
              Loading from cache
           
            - Removing zetacomponents/console-tools (dev-master 90156ab)
            - Installing zetacomponents/console-tools (1.7)
              Loading from cache
           
            - Removing zetacomponents/configuration (dev-master 10ae09f)
            - Installing zetacomponents/configuration (1.4)
              Loading from cache
           
            - Removing zetacomponents/cache (dev-master 34fa794)
            - Installing zetacomponents/cache (1.6)
              Loading from cache
           
            - Removing zetacomponents/authentication-database-tiein (dev-master 56d1e0a)
            - Installing zetacomponents/authentication-database-tiein (1.2)
              Loading from cache
           
            - Removing zetacomponents/archive (dev-master d0caff8)
            - Installing zetacomponents/archive (1.5)
              Loading from cache
           
            - Installing ezsystems/ezwt-ls-extension (v5.3.8)
              Loading from cache
           
            - Installing ezsystems/ezstarrating-ls-extension (v5.3.1)
              Loading from cache
           
            - Installing ezsystems/ezsi-ls (v5.3.3)
              Loading from cache
           
            - Installing ezsystems/ezscriptmonitor-ls (v5.3.1)
              Loading from cache
           
            - Installing ezsystems/ezprestapiprovider-ls (v5.3.0)
              Loading from cache
           
            - Installing ezsystems/ezodf-ls (v5.3.8)
              Loading from cache
           
            - Installing ezsystems/ezmultiupload-ls (v5.3.0)
              Loading from cache
           
            - Installing ezsystems/ezmbpaex-ls (v5.3.2)
              Loading from cache
           
            - Installing ezsystems/ezie-ls (v5.3.1)
              Loading from cache
           
            - Installing ezsystems/ezgmaplocation-ls-extension (v5.3.1)
              Loading from cache
           
            - Installing ezsystems/ezflow-ls-extension (v5.3.8)
              Loading from cache
           
            - Installing ezsystems/ezdemo-ls-extension (v5.3.5)
              Loading from cache
           
            - Installing ezsystems/ezautosave-ls (v5.3.5.1)
              Loading from cache
           
            - Installing ezsystems/ezpublish-legacy (v5.3.8.1)
              Loading from cache
           
            - Installing behat/gherkin (v2.3.5)
              Loading from cache
           
            - Installing behat/behat (v2.5.5)
              Loading from cache
           
            - Installing behat/symfony2-extension (v1.1.2)
              Loading from cache
           
            - Installing behat/mink (v1.7.1)
              Loading from cache
           
            - Installing behat/mink-extension (v1.3.3)
              Loading from cache
           
            - Installing guzzle/common (v3.9.2)
              Loading from cache
           
            - Installing guzzle/stream (v3.9.2)
              Loading from cache
           
            - Installing guzzle/parser (v3.9.2)
              Loading from cache
           
            - Installing guzzle/http (v3.9.2)
              Loading from cache
           
            - Installing fabpot/goutte (v1.0.7)
              Loading from cache
           
            - Installing behat/mink-browserkit-driver (v1.2.0)
              Loading from cache
           
            - Installing behat/mink-goutte-driver (v1.2.1)
              Loading from cache
           
            - Installing behat/mink-sahi-driver (v1.2.1)
              Loading from cache
           
            - Installing instaclick/php-webdriver (1.4.3)
              Loading from cache
           
            - Installing behat/mink-selenium2-driver (v1.3.1)
              Loading from cache
           
            - Installing phpunit/php-text-template (1.2.1)
              Loading from cache
           
            - Installing phpunit/phpunit-mock-objects (1.2.3)
              Loading from cache
           
            - Installing phpunit/php-timer (1.0.8)
              Loading from cache
           
            - Installing phpunit/php-token-stream (1.2.2)
              Loading from cache
           
            - Installing phpunit/php-file-iterator (1.4.1)
              Loading from cache
           
            - Installing phpunit/php-code-coverage (1.2.18)
              Loading from cache
           
            - Installing phpunit/phpunit (3.7.38)
              Loading from cache
           
          paragonie/random_compat suggests installing ext-libsodium (Provides a modern crypto API that can be used to generate random bytes.)
          ezsystems/ezstarrating-ls-extension suggests installing ezsystems/ezwebin-ls-extension (~5.3)
          ezsystems/ezgmaplocation-ls-extension suggests installing ezsystems/ezwebin-ls-extension (~5.3)
          behat/behat suggests installing behat/yii-extension (for integration with Yii web framework)
          behat/mink suggests installing behat/mink-zombie-driver (fast and JS-enabled headless driver for any app (requires node.js))
          phpunit/phpunit-mock-objects suggests installing ext-soap (*)
          phpunit/phpunit suggests installing phpunit/php-invoker (~1.1)
          Package guzzle/common is abandoned, you should avoid using it. Use guzzle/guzzle instead.
          Package guzzle/stream is abandoned, you should avoid using it. Use guzzle/guzzle instead.
          Package guzzle/parser is abandoned, you should avoid using it. Use guzzle/guzzle instead.
          Package guzzle/http is abandoned, you should avoid using it. Use guzzle/guzzle instead.
          Writing lock file
          Generating autoload files
          > Incenteev\ParameterHandler\ScriptHandler::buildParameters
          Updating the "ezpublish/config/parameters.yml" file
          Deprecation Notice: The callback Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::buildBootstrap declared at /var/www/html/ezp53/ezpublish5/vendor/sensio/distribution-bundle/Sensio/Bundle/DistributionBundle/Composer/ScriptHandler.php accepts a Composer\Script\CommandEvent but post-update-cmd events use a Composer\Script\Event instance. Please adjust your type hint accordingly, see https://getcomposer.org/doc/articles/scripts.md#event-classes in phar:///var/www/html/ezp53/ezpublish5/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:289
          > Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::buildBootstrap
          Deprecation Notice: The callback Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::clearCache declared at /var/www/html/ezp53/ezpublish5/vendor/sensio/distribution-bundle/Sensio/Bundle/DistributionBundle/Composer/ScriptHandler.php accepts a Composer\Script\CommandEvent but post-update-cmd events use a Composer\Script\Event instance. Please adjust your type hint accordingly, see https://getcomposer.org/doc/articles/scripts.md#event-classes in phar:///var/www/html/ezp53/ezpublish5/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:289
          > Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::clearCache
          Clearing the cache for the dev environment with debug true
          Clearing Legacy file cache (Template, ini and i18n): 
          Global INI cache, INI cache, Character transformation cache, Template cache, Template block cache, Template override cache, Text to image cache, Design base cache, Active extensions cache, TS Translation cache, SSL Zones cache, eZJSCore Public Packer cache
          Deprecation Notice: The callback Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installAssets declared at /var/www/html/ezp53/ezpublish5/vendor/sensio/distribution-bundle/Sensio/Bundle/DistributionBundle/Composer/ScriptHandler.php accepts a Composer\Script\CommandEvent but post-update-cmd events use a Composer\Script\Event instance. Please adjust your type hint accordingly, see https://getcomposer.org/doc/articles/scripts.md#event-classes in phar:///var/www/html/ezp53/ezpublish5/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:289
          > Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installAssets
          Installing assets using the symlink option
          Installing assets for Symfony\Bundle\FrameworkBundle into web/bundles/framework
          Installing assets for Tedivm\StashBundle into web/bundles/tedivmstash
          Installing assets for EzSystems\DemoBundle into web/bundles/ezdemo
          Installing assets for WhiteOctober\PagerfantaBundle into web/bundles/whiteoctoberpagerfanta
          Installing assets for Sensio\Bundle\DistributionBundle into web/bundles/sensiodistribution
          Deprecation Notice: The callback eZ\Bundle\EzPublishLegacyBundle\Composer\ScriptHandler::installAssets declared at /var/www/html/ezp53/ezpublish5/vendor/ezsystems/ezpublish-kernel/eZ/Bundle/EzPublishLegacyBundle/Composer/ScriptHandler.php accepts a Composer\Script\CommandEvent but post-update-cmd events use a Composer\Script\Event instance. Please adjust your type hint accordingly, see https://getcomposer.org/doc/articles/scripts.md#event-classes in phar:///var/www/html/ezp53/ezpublish5/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:289
          > eZ\Bundle\EzPublishLegacyBundle\Composer\ScriptHandler::installAssets
          Installing eZ Publish legacy assets from /var/www/html/ezp53/ezpublish5/ezpublish/../ezpublish_legacy using the symlink option
          Installing wrappers for eZ Publish legacy front controllers (rest & cluster) with path ../ezpublish_legacy/
          Deprecation Notice: The callback eZ\Bundle\EzPublishCoreBundle\Composer\ScriptHandler::dumpAssets declared at /var/www/html/ezp53/ezpublish5/vendor/ezsystems/ezpublish-kernel/eZ/Bundle/EzPublishCoreBundle/Composer/ScriptHandler.php accepts a Composer\Script\CommandEvent but post-update-cmd events use a Composer\Script\Event instance. Please adjust your type hint accordingly, see https://getcomposer.org/doc/articles/scripts.md#event-classes in phar:///var/www/html/ezp53/ezpublish5/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:289
          > eZ\Bundle\EzPublishCoreBundle\Composer\ScriptHandler::dumpAssets
          Which environment would you like to dump production assets for? (Default: 'prod', type 'none' to skip) prod
          Dumping all prod assets.
          Debug mode is off.
           
          18:56:57 [file+] web/css/3c5fbcb.css
          18:56:57 [file+] web/js/f110395.js
          Deprecation Notice: The callback Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installRequirementsFile declared at /var/www/html/ezp53/ezpublish5/vendor/sensio/distribution-bundle/Sensio/Bundle/DistributionBundle/Composer/ScriptHandler.php accepts a Composer\Script\CommandEvent but post-update-cmd events use a Composer\Script\Event instance. Please adjust your type hint accordingly, see https://getcomposer.org/doc/articles/scripts.md#event-classes in phar:///var/www/html/ezp53/ezpublish5/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:289
          > Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installRequirementsFile
          Deprecation Notice: The callback eZ\Bundle\EzPublishLegacyBundle\Composer\ScriptHandler::installLegacyBundlesExtensions declared at /var/www/html/ezp53/ezpublish5/vendor/ezsystems/ezpublish-kernel/eZ/Bundle/EzPublishLegacyBundle/Composer/ScriptHandler.php accepts a Composer\Script\CommandEvent but post-update-cmd events use a Composer\Script\Event instance. Please adjust your type hint accordingly, see https://getcomposer.org/doc/articles/scripts.md#event-classes in phar:///var/www/html/ezp53/ezpublish5/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:289
          > eZ\Bundle\EzPublishLegacyBundle\Composer\ScriptHandler::installLegacyBundlesExtensions
          - vendor/ezsystems/comments-bundle/EzSystems/CommentsBundle/ezpublish_legacy/ezcommentsbundle
            linked to /var/www/html/ezp53/ezpublish5/ezpublish/../ezpublish_legacy/extension/ezcommentsbundle
          

          Show
          Paulo Nunes (Inactive) added a comment - André Rømcke : replacing the update i.e, replace php -d memory_limit=-1 composer.phar update --no-dev --prefer-dist --with-dependencies ezsystems/ezpublish-kernel ezsystems/demobundle ezsystems/ezpublish-legacy symfony/symfony ezsystems/ezpublish-legacy-installer by php -d memory_limit=-1 composer.phar update --prefer-dist Then the error no longer happens. Only a deprecation notice remains Deprecation Notice: The callback Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installRequirementsFile declared at /var/www/html/ezp53/ezpublish5/vendor/sensio/distribution-bundle/Sensio/Bundle/DistributionBundle/Composer/ScriptHandler.php accepts a Composer\Script\CommandEvent but post-update-cmd events use a Composer\Script\Event instance. Please adjust your type hint accordingly, see https://getcomposer.org/doc/articles/scripts.md#event-classes in phar:///var/www/html/ezp53/ezpublish5/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:289 Just for future memory (mine), the commands executed and output were php -d memory_limit=-1 composer.phar remove --no-update zetacomponents/archive zetacomponents/authentication zetacomponents/authentication-database-tiein zetacomponents/base zetacomponents/cache zetacomponents/configuration zetacomponents/console-tools zetacomponents/database zetacomponents/debug zetacomponents/event-log zetacomponents/feed zetacomponents/image-conversion zetacomponents/mail zetacomponents/mvc-tools zetacomponents/mvc-authentication-tiein zetacomponents/persistent-object zetacomponents/php-generator zetacomponents/signal-slot zetacomponents/system-information The "ezsystems/ezpublish-legacy-installer" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option. The "bitexpert/composer-authstore-plugin" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option. You are running composer with xdebug enabled. This has a major impact on runtime performance. See https://getcomposer.org/xdebug (COS-6.5)vagrant:{/var/www/html/ezp53/ezpublish5}-> php -d memory_limit=-1 composer.phar remove --no-update --dev behat/mink-selenium-driver The "ezsystems/ezpublish-legacy-installer" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option. The "bitexpert/composer-authstore-plugin" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option. You are running composer with xdebug enabled. This has a major impact on runtime performance. See https://getcomposer.org/xdebug (COS-6.5)vagrant:{/var/www/html/ezp53/ezpublish5}-> (COS-6.5)vagrant:{/var/www/html/ezp53/ezpublish5}-> php -d memory_limit=-1 composer.phar remove --no-update bitexpert/composer-authstore-plugin The "ezsystems/ezpublish-legacy-installer" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option. The "bitexpert/composer-authstore-plugin" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option. You are running composer with xdebug enabled. This has a major impact on runtime performance. See https://getcomposer.org/xdebug (COS-6.5)vagrant:{/var/www/html/ezp53/ezpublish5}-> (COS-6.5)vagrant:{/var/www/html/ezp53/ezpublish5}-> (COS-6.5)vagrant:{/var/www/html/ezp53/ezpublish5}-> php -d memory_limit=-1 composer.phar update --prefer-dist The "ezsystems/ezpublish-legacy-installer" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option. The "bitexpert/composer-authstore-plugin" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option. You are running composer with xdebug enabled. This has a major impact on runtime performance. See https://getcomposer.org/xdebug Loading composer repositories with package information Updating dependencies (including require-dev) - Removing symfony/icu (v1.1.1) - Removing bitexpert/composer-authstore-plugin (0.2.1) - Removing ezsystems/ezpublish-legacy-installer (v2.0.0) - Installing ezsystems/ezpublish-legacy-installer (v2.0.3) Loading from cache   - Removing twig/twig (v1.15.1) - Installing twig/twig (v1.24.1) Loading from cache   - Removing doctrine/lexer (v1.0) - Installing doctrine/lexer (v1.0.1) Loading from cache   - Removing doctrine/inflector (v1.0) - Installing doctrine/inflector (v1.1.0) Loading from cache   - Removing doctrine/collections (v1.2) - Installing doctrine/collections (v1.3.0) Loading from cache   - Removing doctrine/cache (v1.3.0) - Installing doctrine/cache (v1.5.4) Loading from cache   - Removing doctrine/annotations (v1.1.2) - Installing doctrine/annotations (v1.2.7) Loading from cache   - Removing doctrine/common (v2.4.2) - Installing doctrine/common (v2.5.3) Loading from cache   - Installing symfony/polyfill-mbstring (v1.2.0) Loading from cache   - Installing symfony/polyfill-apcu (v1.2.0) Loading from cache   - Installing paragonie/random_compat (v1.4.1) Loading from cache   - Removing symfony/symfony (v2.3.13) - Installing symfony/symfony (v2.3.42) Loading from cache   - Removing kriswallsmith/assetic (v1.1.2) - Installing kriswallsmith/assetic (v1.1.3) Loading from cache   - Removing symfony/assetic-bundle (v2.3.0) - Installing symfony/assetic-bundle (v2.3.1) Loading from cache   - Removing swiftmailer/swiftmailer (v5.2.0) - Installing swiftmailer/swiftmailer (v5.4.2) Loading from cache   - Removing symfony/swiftmailer-bundle (v2.3.7) - Installing symfony/swiftmailer-bundle (v2.3.11) Loading from cache   - Removing sensio/distribution-bundle (v2.3.4) - Installing sensio/distribution-bundle (v2.3.22) Loading from cache   - Removing sensio/generator-bundle (v2.3.4) - Installing sensio/generator-bundle (v2.3.5) Loading from cache   - Removing incenteev/composer-parameter-handler (v2.1.0) - Installing incenteev/composer-parameter-handler (v2.1.2) Loading from cache   - Installing netgen/ngsymfonytools (1.1) Loading from cache   - Removing ezsystems/ngsymfonytools-bundle (v1.0.4) - Installing ezsystems/ngsymfonytools-bundle (v1.0.5) Loading from cache   - Removing zetacomponents/base (dev-master 642f63a) - Installing zetacomponents/base (1.9) Loading from cache   - Removing zetacomponents/mail (1.8beta1) - Installing zetacomponents/mail (1.8.1) Loading from cache   - Removing pagerfanta/pagerfanta (v1.0.1) - Installing pagerfanta/pagerfanta (v1.0.3) Loading from cache   - Removing zendframework/zend-stdlib (2.2.6) - Installing zendframework/zend-stdlib (2.2.10) Loading from cache   - Removing zendframework/zend-eventmanager (2.2.6) - Installing zendframework/zend-eventmanager (2.2.10) Loading from cache   - Removing zendframework/zend-code (2.2.6) - Installing zendframework/zend-code (2.2.10) Loading from cache   - Removing ocramius/proxy-manager (0.5.1) - Installing ocramius/proxy-manager (1.0.2) Loading from cache   - Removing nelmio/cors-bundle (1.3.0) - Installing nelmio/cors-bundle (1.3.3) Loading from cache   - Removing kriswallsmith/buzz (v0.10) - Installing kriswallsmith/buzz (v0.15) Loading from cache   - Removing doctrine/dbal (v2.4.2) - Installing doctrine/dbal (v2.4.5) Loading from cache   - Removing ezsystems/ezpublish-kernel (v5.3.0) - Installing ezsystems/ezpublish-kernel (v5.3.8) Loading from cache   - Removing zetacomponents/php-generator (dev-master b51935e) - Installing zetacomponents/php-generator (1.1) Loading from cache   - Removing ezsystems/comments-bundle (v5.3.0) - Installing ezsystems/comments-bundle (v5.3.2) Loading from cache   - Removing ezsystems/demobundle (v5.3.0) - Installing ezsystems/demobundle (v5.3.5) Loading from cache   - Removing egulias/listeners-debug-command-bundle (1.9.0) - Installing egulias/listeners-debug-command-bundle (1.9.1) Loading from cache   - Removing white-october/pagerfanta-bundle (v1.0.2) - Installing white-october/pagerfanta-bundle (v1.0.6) Loading from cache   - Removing monolog/monolog (1.9.1) - Installing monolog/monolog (1.19.0) Loading from cache   - Removing zetacomponents/image-analysis (1.1.3) - Installing zetacomponents/image-analysis (1.2) Loading from cache   - Installing behat/sahi-client (dev-master edd87e8) Loading from cache   - Installing ezsystems/behatbundle (v5.3.0) Loading from cache   - Removing zetacomponents/webdav (1.1.3) - Installing zetacomponents/webdav (1.2) Loading from cache   - Removing zetacomponents/system-information (dev-master 6743362) - Installing zetacomponents/system-information (1.1) Loading from cache   - Removing zetacomponents/signal-slot (dev-master 74deb41) - Installing zetacomponents/signal-slot (1.2) Loading from cache   - Removing zetacomponents/persistent-object (dev-master a4c8b95) - Installing zetacomponents/persistent-object (1.8) Loading from cache   - Removing zetacomponents/mvc-tools (dev-master 6f2c1eb) - Installing zetacomponents/mvc-tools (1.2.1) Loading from cache   - Removing zetacomponents/authentication (dev-master c422670) - Installing zetacomponents/authentication (1.4) Loading from cache   - Removing zetacomponents/mvc-authentication-tiein (dev-master 9bae3a7) - Installing zetacomponents/mvc-authentication-tiein (1.1) Loading from cache   - Removing zetacomponents/image-conversion (dev-master 36f34c8) - Installing zetacomponents/image-conversion (1.4) Loading from cache   - Removing zetacomponents/feed (dev-master e0190e9) - Installing zetacomponents/feed (1.4) Loading from cache   - Removing zetacomponents/event-log (dev-master eee54a1) - Installing zetacomponents/event-log (1.5) Loading from cache   - Removing zetacomponents/debug (dev-master 0d8cc8f) - Installing zetacomponents/debug (1.3) Loading from cache   - Removing zetacomponents/database (dev-master 0e8ddef) - Installing zetacomponents/database (1.5) Loading from cache   - Removing zetacomponents/console-tools (dev-master 90156ab) - Installing zetacomponents/console-tools (1.7) Loading from cache   - Removing zetacomponents/configuration (dev-master 10ae09f) - Installing zetacomponents/configuration (1.4) Loading from cache   - Removing zetacomponents/cache (dev-master 34fa794) - Installing zetacomponents/cache (1.6) Loading from cache   - Removing zetacomponents/authentication-database-tiein (dev-master 56d1e0a) - Installing zetacomponents/authentication-database-tiein (1.2) Loading from cache   - Removing zetacomponents/archive (dev-master d0caff8) - Installing zetacomponents/archive (1.5) Loading from cache   - Installing ezsystems/ezwt-ls-extension (v5.3.8) Loading from cache   - Installing ezsystems/ezstarrating-ls-extension (v5.3.1) Loading from cache   - Installing ezsystems/ezsi-ls (v5.3.3) Loading from cache   - Installing ezsystems/ezscriptmonitor-ls (v5.3.1) Loading from cache   - Installing ezsystems/ezprestapiprovider-ls (v5.3.0) Loading from cache   - Installing ezsystems/ezodf-ls (v5.3.8) Loading from cache   - Installing ezsystems/ezmultiupload-ls (v5.3.0) Loading from cache   - Installing ezsystems/ezmbpaex-ls (v5.3.2) Loading from cache   - Installing ezsystems/ezie-ls (v5.3.1) Loading from cache   - Installing ezsystems/ezgmaplocation-ls-extension (v5.3.1) Loading from cache   - Installing ezsystems/ezflow-ls-extension (v5.3.8) Loading from cache   - Installing ezsystems/ezdemo-ls-extension (v5.3.5) Loading from cache   - Installing ezsystems/ezautosave-ls (v5.3.5.1) Loading from cache   - Installing ezsystems/ezpublish-legacy (v5.3.8.1) Loading from cache   - Installing behat/gherkin (v2.3.5) Loading from cache   - Installing behat/behat (v2.5.5) Loading from cache   - Installing behat/symfony2-extension (v1.1.2) Loading from cache   - Installing behat/mink (v1.7.1) Loading from cache   - Installing behat/mink-extension (v1.3.3) Loading from cache   - Installing guzzle/common (v3.9.2) Loading from cache   - Installing guzzle/stream (v3.9.2) Loading from cache   - Installing guzzle/parser (v3.9.2) Loading from cache   - Installing guzzle/http (v3.9.2) Loading from cache   - Installing fabpot/goutte (v1.0.7) Loading from cache   - Installing behat/mink-browserkit-driver (v1.2.0) Loading from cache   - Installing behat/mink-goutte-driver (v1.2.1) Loading from cache   - Installing behat/mink-sahi-driver (v1.2.1) Loading from cache   - Installing instaclick/php-webdriver (1.4.3) Loading from cache   - Installing behat/mink-selenium2-driver (v1.3.1) Loading from cache   - Installing phpunit/php-text-template (1.2.1) Loading from cache   - Installing phpunit/phpunit-mock-objects (1.2.3) Loading from cache   - Installing phpunit/php-timer (1.0.8) Loading from cache   - Installing phpunit/php-token-stream (1.2.2) Loading from cache   - Installing phpunit/php-file-iterator (1.4.1) Loading from cache   - Installing phpunit/php-code-coverage (1.2.18) Loading from cache   - Installing phpunit/phpunit (3.7.38) Loading from cache   paragonie/random_compat suggests installing ext-libsodium (Provides a modern crypto API that can be used to generate random bytes.) ezsystems/ezstarrating-ls-extension suggests installing ezsystems/ezwebin-ls-extension (~5.3) ezsystems/ezgmaplocation-ls-extension suggests installing ezsystems/ezwebin-ls-extension (~5.3) behat/behat suggests installing behat/yii-extension (for integration with Yii web framework) behat/mink suggests installing behat/mink-zombie-driver (fast and JS-enabled headless driver for any app (requires node.js)) phpunit/phpunit-mock-objects suggests installing ext-soap (*) phpunit/phpunit suggests installing phpunit/php-invoker (~1.1) Package guzzle/common is abandoned, you should avoid using it. Use guzzle/guzzle instead. Package guzzle/stream is abandoned, you should avoid using it. Use guzzle/guzzle instead. Package guzzle/parser is abandoned, you should avoid using it. Use guzzle/guzzle instead. Package guzzle/http is abandoned, you should avoid using it. Use guzzle/guzzle instead. Writing lock file Generating autoload files > Incenteev\ParameterHandler\ScriptHandler::buildParameters Updating the "ezpublish/config/parameters.yml" file Deprecation Notice: The callback Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::buildBootstrap declared at /var/www/html/ezp53/ezpublish5/vendor/sensio/distribution-bundle/Sensio/Bundle/DistributionBundle/Composer/ScriptHandler.php accepts a Composer\Script\CommandEvent but post-update-cmd events use a Composer\Script\Event instance. Please adjust your type hint accordingly, see https://getcomposer.org/doc/articles/scripts.md#event-classes in phar:///var/www/html/ezp53/ezpublish5/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:289 > Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::buildBootstrap Deprecation Notice: The callback Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::clearCache declared at /var/www/html/ezp53/ezpublish5/vendor/sensio/distribution-bundle/Sensio/Bundle/DistributionBundle/Composer/ScriptHandler.php accepts a Composer\Script\CommandEvent but post-update-cmd events use a Composer\Script\Event instance. Please adjust your type hint accordingly, see https://getcomposer.org/doc/articles/scripts.md#event-classes in phar:///var/www/html/ezp53/ezpublish5/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:289 > Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::clearCache Clearing the cache for the dev environment with debug true Clearing Legacy file cache (Template, ini and i18n): Global INI cache, INI cache, Character transformation cache, Template cache, Template block cache, Template override cache, Text to image cache, Design base cache, Active extensions cache, TS Translation cache, SSL Zones cache, eZJSCore Public Packer cache Deprecation Notice: The callback Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installAssets declared at /var/www/html/ezp53/ezpublish5/vendor/sensio/distribution-bundle/Sensio/Bundle/DistributionBundle/Composer/ScriptHandler.php accepts a Composer\Script\CommandEvent but post-update-cmd events use a Composer\Script\Event instance. Please adjust your type hint accordingly, see https://getcomposer.org/doc/articles/scripts.md#event-classes in phar:///var/www/html/ezp53/ezpublish5/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:289 > Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installAssets Installing assets using the symlink option Installing assets for Symfony\Bundle\FrameworkBundle into web/bundles/framework Installing assets for Tedivm\StashBundle into web/bundles/tedivmstash Installing assets for EzSystems\DemoBundle into web/bundles/ezdemo Installing assets for WhiteOctober\PagerfantaBundle into web/bundles/whiteoctoberpagerfanta Installing assets for Sensio\Bundle\DistributionBundle into web/bundles/sensiodistribution Deprecation Notice: The callback eZ\Bundle\EzPublishLegacyBundle\Composer\ScriptHandler::installAssets declared at /var/www/html/ezp53/ezpublish5/vendor/ezsystems/ezpublish-kernel/eZ/Bundle/EzPublishLegacyBundle/Composer/ScriptHandler.php accepts a Composer\Script\CommandEvent but post-update-cmd events use a Composer\Script\Event instance. Please adjust your type hint accordingly, see https://getcomposer.org/doc/articles/scripts.md#event-classes in phar:///var/www/html/ezp53/ezpublish5/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:289 > eZ\Bundle\EzPublishLegacyBundle\Composer\ScriptHandler::installAssets Installing eZ Publish legacy assets from /var/www/html/ezp53/ezpublish5/ezpublish/../ezpublish_legacy using the symlink option Installing wrappers for eZ Publish legacy front controllers (rest & cluster) with path ../ezpublish_legacy/ Deprecation Notice: The callback eZ\Bundle\EzPublishCoreBundle\Composer\ScriptHandler::dumpAssets declared at /var/www/html/ezp53/ezpublish5/vendor/ezsystems/ezpublish-kernel/eZ/Bundle/EzPublishCoreBundle/Composer/ScriptHandler.php accepts a Composer\Script\CommandEvent but post-update-cmd events use a Composer\Script\Event instance. Please adjust your type hint accordingly, see https://getcomposer.org/doc/articles/scripts.md#event-classes in phar:///var/www/html/ezp53/ezpublish5/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:289 > eZ\Bundle\EzPublishCoreBundle\Composer\ScriptHandler::dumpAssets Which environment would you like to dump production assets for? (Default: 'prod', type 'none' to skip) prod Dumping all prod assets. Debug mode is off.   18:56:57 [file+] web/css/3c5fbcb.css 18:56:57 [file+] web/js/f110395.js Deprecation Notice: The callback Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installRequirementsFile declared at /var/www/html/ezp53/ezpublish5/vendor/sensio/distribution-bundle/Sensio/Bundle/DistributionBundle/Composer/ScriptHandler.php accepts a Composer\Script\CommandEvent but post-update-cmd events use a Composer\Script\Event instance. Please adjust your type hint accordingly, see https://getcomposer.org/doc/articles/scripts.md#event-classes in phar:///var/www/html/ezp53/ezpublish5/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:289 > Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installRequirementsFile Deprecation Notice: The callback eZ\Bundle\EzPublishLegacyBundle\Composer\ScriptHandler::installLegacyBundlesExtensions declared at /var/www/html/ezp53/ezpublish5/vendor/ezsystems/ezpublish-kernel/eZ/Bundle/EzPublishLegacyBundle/Composer/ScriptHandler.php accepts a Composer\Script\CommandEvent but post-update-cmd events use a Composer\Script\Event instance. Please adjust your type hint accordingly, see https://getcomposer.org/doc/articles/scripts.md#event-classes in phar:///var/www/html/ezp53/ezpublish5/composer.phar/src/Composer/EventDispatcher/EventDispatcher.php:289 > eZ\Bundle\EzPublishLegacyBundle\Composer\ScriptHandler::installLegacyBundlesExtensions - vendor/ezsystems/comments-bundle/EzSystems/CommentsBundle/ezpublish_legacy/ezcommentsbundle linked to /var/www/html/ezp53/ezpublish5/ezpublish/../ezpublish_legacy/extension/ezcommentsbundle
          Hide
          André Rømcke added a comment - - edited

          5.3.x and 5.4.x update instructions are updated and hence available to all customers already.

          As a bonus this made the manually step to add other ez packages people use to the instructions unnecessary.

          https://doc.ez.no/display/EZP/5.3.x+Update+Instructions
          https://doc.ez.no/display/EZP/5.4.x+Update+Instructions

          Show
          André Rømcke added a comment - - edited 5.3.x and 5.4.x update instructions are updated and hence available to all customers already. As a bonus this made the manually step to add other ez packages people use to the instructions unnecessary. https://doc.ez.no/display/EZP/5.3.x+Update+Instructions https://doc.ez.no/display/EZP/5.4.x+Update+Instructions
          Hide
          Paulo Nunes (Inactive) added a comment -

          In 5.3.x, it worked, as said in previous comment. Used composer 1.1.2

          Testing now with 5.4.x...

          Show
          Paulo Nunes (Inactive) added a comment - In 5.3.x, it worked, as said in previous comment. Used composer 1.1.2 Testing now with 5.4.x...
          Hide
          Paulo Nunes (Inactive) added a comment -

          André Rømcke
          In 5.4.x, I have an error if updating with php -d memory_limit=-1 composer.phar update --prefer-dist
          The error is

          [ErrorException]                                                                                                                             
            Declaration of eZ\Bundle\EzPublishLegacyBundle\Composer\ScriptHandler::installAssets() should be compatible with Sensio\Bundle\Distribution  
            Bundle\Composer\ScriptHandler::installAssets(Composer\Script\Event $event)       
          

          This problem might be solved in EZP-25720, but this fix will only be available with 5.4.7 release.

          Show
          Paulo Nunes (Inactive) added a comment - André Rømcke In 5.4.x, I have an error if updating with php -d memory_limit=-1 composer.phar update --prefer-dist The error is [ErrorException] Declaration of eZ\Bundle\EzPublishLegacyBundle\Composer\ScriptHandler::installAssets() should be compatible with Sensio\Bundle\Distribution Bundle\Composer\ScriptHandler::installAssets(Composer\Script\Event $event) This problem might be solved in EZP-25720 , but this fix will only be available with 5.4.7 release.
          Hide
          Paulo Nunes (Inactive) added a comment -

          André Rømcke, good to go now
          Just upgraded a 5.4.0->5.4.6 following updated instructions and the errors no longer occurs.

          Just for the record of the current issue
          upgrade from 5.3.0->5.3.8 worked without errors
          upgrade from 5.4.0->5.4.6 worked without errors

          Both upgrades were done using composer 1.1.2

          Show
          Paulo Nunes (Inactive) added a comment - André Rømcke , good to go now Just upgraded a 5.4.0->5.4.6 following updated instructions and the errors no longer occurs. Just for the record of the current issue upgrade from 5.3.0->5.3.8 worked without errors upgrade from 5.4.0->5.4.6 worked without errors Both upgrades were done using composer 1.1.2
          Hide
          Paulo Nunes (Inactive) added a comment -

          Verified by QA

          Show
          Paulo Nunes (Inactive) added a comment - Verified by QA

            People

            • Assignee:
              Unassigned
              Reporter:
              Rui Silva (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: