Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-25774

Cannot update 5.3.x and 5.4.x using latest composer version

    Details

      Description

      Currently cannot install an up-to-date 5.3, neither via the tarball with subsequent update process from the documentation, nor using git.

      When running the command from the documentation to update:

      php -d memory_limit=-1 composer.phar update --no-dev --prefer-dist --with-dependencies ezsystems/ezpublish-kernel ezsystems/demobundle ezsystems/ezpublish-legacy symfony/symfony
      

      or when running the command:

      php  -d memory_limit=-1 composer.phar install --prefer-dist --no-dev
      

      to install my ezpublish fetched from git, I get the following error:

      Updating dependencies
      Your requirements could not be resolved to an installable set of packages.
       
        Problem 1
          - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
          - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
          - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
          - Installation request for ezsystems/ezpublish-legacy-installer (locked at v2.0.0) -> satisfiable by ezsystems/ezpublish-legacy-installer[v2.0.0].
       
      Potential causes:
       - A typo in the package name
       - The package is not available in a stable-enough version according to your minimum-stability setting
         see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.
       
      Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
      

      It appears this happens since update to last version of composer 1.1.0, from May the 10th, 2016 (two days ago)
      However, if I manually fetch a previous version such as 1.0.3, for instance, it does work.

        Issue Links

          Activity

          Rui Silva (Inactive) created issue -
          Rui Silva (Inactive) made changes -
          Field Original Value New Value
          Link This issue relates to EZP-25600 [ EZP-25600 ]
          Rui Silva (Inactive) made changes -
          Description Currently cannot install an up-to-date 5.3, neither via the tarball with subsequent update process from the documentation, nor using git.

          When running the command from the [documentation|https://doc.ez.no/display/EZP/5.3.x+Update+Instructions] to update:
          {noformat}
          php -d memory_limit=-1 composer.phar update --no-dev --prefer-dist --with-dependencies ezsystems/ezpublish-kernel ezsystems/demobundle ezsystems/ezpublish-legacy symfony/symfony
          {noformat}
          or when running the command:
          {noformat}
          php -d memory_limit=-1 composer.phar install --prefer-dist --no-dev
          {noformat}
          to install my ezpublish fetched from git, I get the following error:

          {noformat}
          Updating dependencies
          Your requirements could not be resolved to an installable set of packages.

            Problem 1
              - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
              - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
              - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
              - Installation request for ezsystems/ezpublish-legacy-installer (locked at v2.0.0) -> satisfiable by ezsystems/ezpublish-legacy-installer[v2.0.0].

          Potential causes:
           - A typo in the package name
           - The package is not available in a stable-enough version according to your minimum-stability setting
             see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

          Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
          {noformat}

          It appears this happens since update to last version of composer 1.1.0, from May the 10th, 2016 (two days ago)
          However, if I manually a previous version such as 1.0.3, for instance, it does work.
          Currently cannot install an up-to-date 5.3, neither via the tarball with subsequent update process from the documentation, nor using git.

          When running the command from the [documentation|https://doc.ez.no/display/EZP/5.3.x+Update+Instructions] to update:
          {noformat}
          php -d memory_limit=-1 composer.phar update --no-dev --prefer-dist --with-dependencies ezsystems/ezpublish-kernel ezsystems/demobundle ezsystems/ezpublish-legacy symfony/symfony
          {noformat}
          or when running the command:
          {noformat}
          php -d memory_limit=-1 composer.phar install --prefer-dist --no-dev
          {noformat}
          to install my ezpublish fetched from git, I get the following error:

          {noformat}
          Updating dependencies
          Your requirements could not be resolved to an installable set of packages.

            Problem 1
              - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
              - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
              - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
              - Installation request for ezsystems/ezpublish-legacy-installer (locked at v2.0.0) -> satisfiable by ezsystems/ezpublish-legacy-installer[v2.0.0].

          Potential causes:
           - A typo in the package name
           - The package is not available in a stable-enough version according to your minimum-stability setting
             see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

          Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
          {noformat}

          It appears this happens since update to last version of composer 1.1.0, from May the 10th, 2016 (two days ago)
          However, if I manually a previous version such as 1.0.3, for instance, it does work.

          QA is unsure if this issue might somewhat be related to the jira put as related link to this jira.
          Rui Silva (Inactive) made changes -
          Status Open [ 1 ] Confirmed [ 10037 ]
          Paulo Nunes (Inactive) made changes -
          Affects Version/s 5.3.8 [ 14382 ]
          Affects Version/s 5.3 [ 11282 ]
          Paulo Nunes (Inactive) made changes -
          Description Currently cannot install an up-to-date 5.3, neither via the tarball with subsequent update process from the documentation, nor using git.

          When running the command from the [documentation|https://doc.ez.no/display/EZP/5.3.x+Update+Instructions] to update:
          {noformat}
          php -d memory_limit=-1 composer.phar update --no-dev --prefer-dist --with-dependencies ezsystems/ezpublish-kernel ezsystems/demobundle ezsystems/ezpublish-legacy symfony/symfony
          {noformat}
          or when running the command:
          {noformat}
          php -d memory_limit=-1 composer.phar install --prefer-dist --no-dev
          {noformat}
          to install my ezpublish fetched from git, I get the following error:

          {noformat}
          Updating dependencies
          Your requirements could not be resolved to an installable set of packages.

            Problem 1
              - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
              - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
              - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
              - Installation request for ezsystems/ezpublish-legacy-installer (locked at v2.0.0) -> satisfiable by ezsystems/ezpublish-legacy-installer[v2.0.0].

          Potential causes:
           - A typo in the package name
           - The package is not available in a stable-enough version according to your minimum-stability setting
             see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

          Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
          {noformat}

          It appears this happens since update to last version of composer 1.1.0, from May the 10th, 2016 (two days ago)
          However, if I manually a previous version such as 1.0.3, for instance, it does work.

          QA is unsure if this issue might somewhat be related to the jira put as related link to this jira.
          Currently cannot install an up-to-date 5.3, neither via the tarball with subsequent update process from the documentation, nor using git.

          When running the command from the [documentation|https://doc.ez.no/display/EZP/5.3.x+Update+Instructions] to update:
          {noformat}
          php -d memory_limit=-1 composer.phar update --no-dev --prefer-dist --with-dependencies ezsystems/ezpublish-kernel ezsystems/demobundle ezsystems/ezpublish-legacy symfony/symfony
          {noformat}
          or when running the command:
          {noformat}
          php -d memory_limit=-1 composer.phar install --prefer-dist --no-dev
          {noformat}
          to install my ezpublish fetched from git, I get the following error:

          {noformat}
          Updating dependencies
          Your requirements could not be resolved to an installable set of packages.

            Problem 1
              - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
              - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
              - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
              - Installation request for ezsystems/ezpublish-legacy-installer (locked at v2.0.0) -> satisfiable by ezsystems/ezpublish-legacy-installer[v2.0.0].

          Potential causes:
           - A typo in the package name
           - The package is not available in a stable-enough version according to your minimum-stability setting
             see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

          Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
          {noformat}

          It appears this happens since update to last version of composer 1.1.0, from May the 10th, 2016 (two days ago)
          However, if I manually a previous version such as 1.0.3, for instance, it does work.
          Paulo Nunes (Inactive) made changes -
          Summary Cannot install updated 5.3 Cannot update 5.3.x using latest composer version
          Paulo Nunes (Inactive) made changes -
          Link This issue relates to EZP-25582 [ EZP-25582 ]
          Paulo Nunes (Inactive) made changes -
          Priority High [ 3 ] Critical [ 2 ]
          André Rømcke made changes -
          Status Confirmed [ 10037 ] Backlog [ 10000 ]
          André Rømcke made changes -
          Status Backlog [ 10000 ] Development [ 3 ]
          Assignee André Rømcke [ andre.romcke@ez.no ]
          André Rømcke made changes -
          Status Development [ 3 ] Development Review done [ 10028 ]
          Assignee André Rømcke [ andre.romcke@ez.no ]
          André Rømcke made changes -
          Status Development Review done [ 10028 ] Documentation Review done [ 10011 ]
          Rui Silva (Inactive) made changes -
          Status Documentation Review done [ 10011 ] QA [ 10008 ]
          Paulo Nunes (Inactive) made changes -
          Assignee Rui Silva [ rui.silva@ez.no ] Paulo Nunes [ paulo.nunes@ez.no ]
          Paulo Nunes (Inactive) made changes -
          Summary Cannot update 5.3.x using latest composer version Cannot update 5.3.x and 5.4.x using latest composer version
          Paulo Nunes (Inactive) made changes -
          Affects Version/s 5.4.6 [ 14493 ]
          Rui Silva (Inactive) made changes -
          Description Currently cannot install an up-to-date 5.3, neither via the tarball with subsequent update process from the documentation, nor using git.

          When running the command from the [documentation|https://doc.ez.no/display/EZP/5.3.x+Update+Instructions] to update:
          {noformat}
          php -d memory_limit=-1 composer.phar update --no-dev --prefer-dist --with-dependencies ezsystems/ezpublish-kernel ezsystems/demobundle ezsystems/ezpublish-legacy symfony/symfony
          {noformat}
          or when running the command:
          {noformat}
          php -d memory_limit=-1 composer.phar install --prefer-dist --no-dev
          {noformat}
          to install my ezpublish fetched from git, I get the following error:

          {noformat}
          Updating dependencies
          Your requirements could not be resolved to an installable set of packages.

            Problem 1
              - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
              - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
              - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
              - Installation request for ezsystems/ezpublish-legacy-installer (locked at v2.0.0) -> satisfiable by ezsystems/ezpublish-legacy-installer[v2.0.0].

          Potential causes:
           - A typo in the package name
           - The package is not available in a stable-enough version according to your minimum-stability setting
             see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

          Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
          {noformat}

          It appears this happens since update to last version of composer 1.1.0, from May the 10th, 2016 (two days ago)
          However, if I manually a previous version such as 1.0.3, for instance, it does work.
          Currently cannot install an up-to-date 5.3, neither via the tarball with subsequent update process from the documentation, nor using git.

          When running the command from the [documentation|https://doc.ez.no/display/EZP/5.3.x+Update+Instructions] to update:
          {noformat}
          php -d memory_limit=-1 composer.phar update --no-dev --prefer-dist --with-dependencies ezsystems/ezpublish-kernel ezsystems/demobundle ezsystems/ezpublish-legacy symfony/symfony
          {noformat}
          or when running the command:
          {noformat}
          php -d memory_limit=-1 composer.phar install --prefer-dist --no-dev
          {noformat}
          to install my ezpublish fetched from git, I get the following error:

          {noformat}
          Updating dependencies
          Your requirements could not be resolved to an installable set of packages.

            Problem 1
              - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
              - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
              - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
              - Installation request for ezsystems/ezpublish-legacy-installer (locked at v2.0.0) -> satisfiable by ezsystems/ezpublish-legacy-installer[v2.0.0].

          Potential causes:
           - A typo in the package name
           - The package is not available in a stable-enough version according to your minimum-stability setting
             see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

          Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
          {noformat}

          It appears this happens since update to last version of composer 1.1.0, from May the 10th, 2016 (two days ago)
          However, if I manually fetch a previous version such as 1.0.3, for instance, it does work.
          Paulo Nunes (Inactive) made changes -
          Status QA [ 10008 ] InputQ [ 10001 ]
          Assignee Paulo Nunes [ paulo.nunes@ez.no ]
          Ricardo Correia (Inactive) made changes -
          Fix Version/s Customer request [ 11018 ]
          Yannick Roger (Inactive) made changes -
          Assignee Yannick Roger [ yannick.roger@ez.no ]
          Paulo Nunes (Inactive) made changes -
          Assignee Yannick Roger [ yannick.roger@ez.no ] Paulo Nunes [ paulo.nunes@ez.no ]
          André Rømcke made changes -
          Status InputQ [ 10001 ] Development [ 3 ]
          Assignee Paulo Nunes [ paulo.nunes@ez.no ] André Rømcke [ andre.romcke@ez.no ]
          André Rømcke made changes -
          Status Development [ 3 ] Development Review [ 10006 ]
          André Rømcke made changes -
          Status Development Review [ 10006 ] Documentation Review done [ 10011 ]
          Fix Version/s 5.4.7 [ 14519 ]
          Fix Version/s 5.3.9 [ 14524 ]
          Assignee André Rømcke [ andre.romcke@ez.no ]
          Paulo Nunes (Inactive) made changes -
          Status Documentation Review done [ 10011 ] QA [ 10008 ]
          Paulo Nunes (Inactive) made changes -
          Assignee Paulo Nunes [ paulo.nunes@ez.no ]
          Status QA [ 10008 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          Eduardo Fernandes (Inactive) made changes -
          Link This issue relates to EZP-26022 [ EZP-26022 ]
          Alex Schuster made changes -
          Workflow EZ* Development Workflow [ 98821 ] EZEE Development Workflow [ 125700 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              Rui Silva (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: