Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-25774

Cannot update 5.3.x and 5.4.x using latest composer version

    Details

      Description

      Currently cannot install an up-to-date 5.3, neither via the tarball with subsequent update process from the documentation, nor using git.

      When running the command from the documentation to update:

      php -d memory_limit=-1 composer.phar update --no-dev --prefer-dist --with-dependencies ezsystems/ezpublish-kernel ezsystems/demobundle ezsystems/ezpublish-legacy symfony/symfony
      

      or when running the command:

      php  -d memory_limit=-1 composer.phar install --prefer-dist --no-dev
      

      to install my ezpublish fetched from git, I get the following error:

      Updating dependencies
      Your requirements could not be resolved to an installable set of packages.
       
        Problem 1
          - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
          - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
          - ezsystems/ezpublish-legacy-installer v2.0.0 requires composer-plugin-api 1.0.0 -> no matching package found.
          - Installation request for ezsystems/ezpublish-legacy-installer (locked at v2.0.0) -> satisfiable by ezsystems/ezpublish-legacy-installer[v2.0.0].
       
      Potential causes:
       - A typo in the package name
       - The package is not available in a stable-enough version according to your minimum-stability setting
         see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.
       
      Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
      

      It appears this happens since update to last version of composer 1.1.0, from May the 10th, 2016 (two days ago)
      However, if I manually fetch a previous version such as 1.0.3, for instance, it does work.

        Issue Links

          Activity

          Hide
          André Rømcke added a comment - - edited

          5.3.x and 5.4.x update instructions are updated and hence available to all customers already.

          As a bonus this made the manually step to add other ez packages people use to the instructions unnecessary.

          https://doc.ez.no/display/EZP/5.3.x+Update+Instructions
          https://doc.ez.no/display/EZP/5.4.x+Update+Instructions

          Show
          André Rømcke added a comment - - edited 5.3.x and 5.4.x update instructions are updated and hence available to all customers already. As a bonus this made the manually step to add other ez packages people use to the instructions unnecessary. https://doc.ez.no/display/EZP/5.3.x+Update+Instructions https://doc.ez.no/display/EZP/5.4.x+Update+Instructions
          Hide
          Paulo Nunes (Inactive) added a comment -

          In 5.3.x, it worked, as said in previous comment. Used composer 1.1.2

          Testing now with 5.4.x...

          Show
          Paulo Nunes (Inactive) added a comment - In 5.3.x, it worked, as said in previous comment. Used composer 1.1.2 Testing now with 5.4.x...
          Hide
          Paulo Nunes (Inactive) added a comment -

          André Rømcke
          In 5.4.x, I have an error if updating with php -d memory_limit=-1 composer.phar update --prefer-dist
          The error is

          [ErrorException]                                                                                                                             
            Declaration of eZ\Bundle\EzPublishLegacyBundle\Composer\ScriptHandler::installAssets() should be compatible with Sensio\Bundle\Distribution  
            Bundle\Composer\ScriptHandler::installAssets(Composer\Script\Event $event)       
          

          This problem might be solved in EZP-25720, but this fix will only be available with 5.4.7 release.

          Show
          Paulo Nunes (Inactive) added a comment - André Rømcke In 5.4.x, I have an error if updating with php -d memory_limit=-1 composer.phar update --prefer-dist The error is [ErrorException] Declaration of eZ\Bundle\EzPublishLegacyBundle\Composer\ScriptHandler::installAssets() should be compatible with Sensio\Bundle\Distribution Bundle\Composer\ScriptHandler::installAssets(Composer\Script\Event $event) This problem might be solved in EZP-25720 , but this fix will only be available with 5.4.7 release.
          Hide
          Paulo Nunes (Inactive) added a comment -

          André Rømcke, good to go now
          Just upgraded a 5.4.0->5.4.6 following updated instructions and the errors no longer occurs.

          Just for the record of the current issue
          upgrade from 5.3.0->5.3.8 worked without errors
          upgrade from 5.4.0->5.4.6 worked without errors

          Both upgrades were done using composer 1.1.2

          Show
          Paulo Nunes (Inactive) added a comment - André Rømcke , good to go now Just upgraded a 5.4.0->5.4.6 following updated instructions and the errors no longer occurs. Just for the record of the current issue upgrade from 5.3.0->5.3.8 worked without errors upgrade from 5.4.0->5.4.6 worked without errors Both upgrades were done using composer 1.1.2
          Hide
          Paulo Nunes (Inactive) added a comment -

          Verified by QA

          Show
          Paulo Nunes (Inactive) added a comment - Verified by QA

            People

            • Assignee:
              Unassigned
              Reporter:
              Rui Silva (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: