Uploaded image for project: 'eZ Publish / Platform'
  1. eZ Publish / Platform
  2. EZP-25739

Problem with german umlaut in URL on the administration backend

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 5.4.6
    • Fix Version/s: Customer request, 5.4.7
    • Component/s: Legacy stack
    • Labels:
      None
    • Environment:

      eZ Publish 5.4.6

      Description

      When using umlaut in the name of an top level object something weird happens on the tree menu creation.

      Tree menu will return "Node does not exist", and child objects listing will return "Data error".

      Steps to reproduce:
      1. Set the follwoing URLTranslator in site.ini

      [URLTranslator]
      TransformationGroup=urlalias_iri
      

      2. Create a folder (from the backend) under Home with name: Folder with ΓΌ on it
      3. Try to access the created folder from the backend
      The url alias will be wrong, since the title was discarded.

      Tree menu will return "Node does not exist", and child objects listing will return "Data error" (see the attached screenshot).

        Issue Links

          Activity

          Show
          Joao Inacio (Inactive) added a comment - PR: https://github.com/ezsystems/LegacyBridge/pull/56
          Show
          Joao Inacio (Inactive) added a comment - Merged into LegacyBridge https://github.com/ezsystems/LegacyBridge/commit/20705aa907ac9916f3f0e808b3dee81e8dacbfe6

            People

            • Assignee:
              Unassigned
              Reporter:
              Ricardo Correia (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: